Showing results for 
Search instead for 
Did you mean: 

Hub 3 Unable to access after placing in Modem Mode

Joining in

Hub 3 placed in Modem mode using my Mac in order to connect a third party mesh system (TP-Link Deco S4). Hub 3 WiFi disabled and I am still able to access the internet via the Hub 3 LAN port with my Mac as expected albeit the Hub 3 did take an age to settle after rebooting into Modem mode with a Red LED - checked here in the community and this is not a fault but a quirk of the LED colourings and should be Magenta.

Given that I was then unable to successfully connect to the internet with my iPhone via the WiFi of the main Deco unit (this was connected to a LAN port on the the Hub 3 via ethernet cabling), I needed to access and check the Hub 3 settings against those of the Deco unit.

I am unable to access the Hub 3 despite using the Modem address As I couldn't access the Hub 3 I cycled power to the Hub 3 in the hope that a re-boot may of enabled a successful connection of the third party mesh system. The re-boot resulted in the Hub 3 simply cycling though a loop for a period of +27 minutes and would not settle into Modem mode. I removed the power for a period of one minute and after powering up the Hub 3 again took an age to settle into Modem mode.

Again I am unsuccessful in connecting my third party mesh system despite checks and changes to  some settings on the Deco side.

Next step was to re-set the Hub 3, once reset back into Router mode I accessed the Hub 3 to place it back into Modem mode. Again a repeat of the above.

To summarise I think I have an issue with the Hub 3 and / or possible VM constraints on the Hub.

Any help would be greatly appreciated.





Trouble shooter

Alessandro Volta
Test with just your Mac with hub in modem mode power off for 2mins turn on and unplug replug Ethernet till you get internet.

You can then try again power 2mins but don't have devices connected to the Deco with the Deco to the hub wait 5mins unplug replug Ethernet and then connect devices to Deco and check you have a WAN IP. If no internet change the WAN MAC on the Deco try again.

Very Insightful Person
Very Insightful Person

How to put a VM hub into modem mode:

1) Access your hub on, sign on and put it into modem mode. On the Hub3 the bottom LED will change to magenta, on a Hub4 the LED band will be green, on a Hub5 the LED will be green. Best done from a wired connection.

2) Turn off the hub and disconnect any Ethernet cables

3) Fully initialise your own router or mesh master unit and make sure the WAN port is set to DHCP (for some routers or mesh this may have to be done in router mode before entering modem mode)

4) Connect your router or mesh master unit to the VM hub with an Ethernet cable, Cat5e or Cat6, any higher specification is a waste of money. On a Hub5 use port 4.

5) Turn on the VM hub.

6) You should now be able to access the internet and the hub will now be on

Note1: this only needs doing once for each new router or when VM changes your WAN IP address.

Note2: If you have a Hub4 and your own router is NOT then it’s possible that you can still access the VM hub on

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

People - thanks for taking the time to reply. After my post I returned the Hub 3 to router mode and deliberately walked away from the issue for 24 hours or so. Sunday when my team went 3-0 down I decided to re-investigate the issue and by chance stumbled on varying similar lines of action to those mentioned here. I would like to point out that the root cause of my issue was my Hub 3 indicating it was in Modem mode when it wasn't - powering down and up on more than once occasion by fluke actually placed the Hub into Modem Mode (LAN port 1 only providing internet access, Red / Magenta LED ON, access to the config menu via address

My fix was this -

Step 1 - Hub 3 in router mode all LAN ports able to access the internet (Mac connected to LAN port 1). No cycling of power of the Hub

Step 2 - I disconnected the Mac from the Hub and and connected LAN port 1 of the main Deco S4 unit into LAN port 1 of the Hub 3 LAN and powered up the main Deco

Step 3 - Connected the Mac into the LAN port 2 of the main Deco

Step 4 - Used the Deco app on my iPhone to register the main Deco - Default configuration on the app for the Deco S4 used. Mac able to surf the internet.

Step 5 - Connected the Mac back into LAN port 2 on the Hub and placed it into Modem mode - no other changes made to the Hub 3 configuration.

Step 6 - Disconnected the Mac from the Hub and re-connected back into LAN port 2 of the Deco

Step 7 - Allowed the Hub to change into Modem mode. On receiving a steady Red/Magenta LED I cycled power and waited until once again I received a steady Red/Magenta LED.

Step 8 - Main Deco and the Mac connected to it will not connect to the internet.

Step 9 - Cycled the power to the Hub 3 once again and waited for a steady Red / Magenta LED - STILL Main Deco and the Mac connected to it will not connect to the internet.

Step 10 - Cycled power to the main Deco -STILL Main Deco and the Mac connected to it will not connect to the internet.

Step 10 - Getting annoyed and by chance repeated step 9 and this time - Mac connected to the internet.

It's possible I may not of cycled power to the Hub and/or the main Deco in the correct sequence but I'm now good thanks and have no problem with anyone pointing to the error of my ways. Satellite Deco units connected in minutes and WiFi dead spots eliminated.


Very Insightful Person
Very Insightful Person

Glad you got it sorted.  Modem mode can be problematic as the Hub/CMTS remembers the last devices MAC address that was  connected and takes a while to forget it.  So when you were swapping between your MAC and Deco, the system got confused and it took the several reboots to sort it all out.

It  should remain stable between reboots in future as long as the Deco is not swapped out for something else, and then it's back to square one  🙂

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks