Menu
Reply
Duc916
  • 6
  • 0
  • 0
Tuning in
184 Views
Message 1 of 5
Flag for a moderator

HUB2 replacement never happened ?? and do no want a new contract to get one?

Hi I have a very old hub2 router where the WPS no longer works or is hit and miss as sticks in / doesnt work, a year ago or so I was promised a new hub when renewing my contract but it never materialised ?

No when I try and replace my old hub2 I can only get a page which gives a new hub but increases my payments and ties me to an extended contract??

I never seem to get through to anyone that can help as its an endless menu or go around in circles on the help pages 

Can someone in VM actually  send me a replacement hub please? 

0 Kudos
Reply
jbrennand
  • 28.96K
  • 2.89K
  • 5.45K
Very Insightful Person
Very Insightful Person
178 Views
Message 2 of 5
Flag for a moderator

Re: HUB2 replacement never happened ?? and do no want a new contract to get one?

VM have a shortage of Hubs at the moment (don't ask). They will only replace it if it is genuinely borked. And even then they are re-issuing SH2's so you may not get a Hub3 (and that may be refurbished too).

Call it in as faulty and see what they have to say as its faulty. A VM person will comment here in a few days

Or do as I do and put the SH2 into modem mode and use your own equipment


--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router +2 Airport Express's. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
Duc916
  • 6
  • 0
  • 0
Tuning in
172 Views
Message 3 of 5
Flag for a moderator

Re: HUB2 replacement never happened ?? and do no want a new contract to get one?

thanks for the advice, think I will be up again for renewal next month, as a customer its always seems a case of you have to look elsewhere to get a result with VM ? Hearing good things about EE in our area - service has been bad in the DE74 area lately and the "smart wifi" upgrade really seems to have spannered using the hub2 as a modem and the connection to my Nighthawk (which I have now had to setup as a booster instead) and go back to using the hub2 as a router - wifi and service seems very flaky since the area upgrades ?
0 Kudos
Reply
gordon861
  • 74
  • 0
  • 21
Dialled in
168 Views
Message 4 of 5
Flag for a moderator

Re: HUB2 replacement never happened ?? and do no want a new contract to get one?

I think they have a shortage because they have no idea who they are sending them to.

Sent me a Hub5 at the start of the month and have just sent me another Hub3, they haven't a clue.

0 Kudos
Reply
jbrennand
  • 28.96K
  • 2.89K
  • 5.45K
Very Insightful Person
Very Insightful Person
163 Views
Message 5 of 5
Flag for a moderator

Re: HUB2 replacement never happened ?? and do no want a new contract to get one?

The "smart wifi" upgrade will have no effect whatsoever if you have the Hub in modem mode and the Nighthawk doing all the heavy lifting. After all in modem mode - the SH2 is just that it has no routing or wifi capabilities.

If you are having issues with that sort of set up, then you should try setting it up again using the correct sequence (see below) , and if that doesnt sort it you may have a connection issue that we can help diagnose

___________________

Set up your own router/Mesh unit (in its settings) with the WAN port set to be in Automatic IP i.e. DHCP (& Nat) mode, it may be pre-set that way anyway. Then, disconnect all cables from your new router (or Mesh first unit) and switch it off and unplug it.

Then, put the VM Hub into modem mode
( https://www.virginmedia.com/help/virgin-media-hub-modem-mode )
and leave it 5-10' to initialise

Once it’s in modem mode, the VM hub “MUST” then be powered off. Switch your router on and make sure it’s fully initialised (leave 5 min) and then put in the ethernet cable from its WAN port to the VM hub (any port will do).

NOW… power up the VM hub and wait 5-10 minutes for The Hub to initialise and and you should get a stable connection. This order only needs to be done the first time you connect the router to the VM hub.

--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router +2 Airport Express's. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.