Showing results for 
Search instead for 
Did you mean: 

Connect app

Joining in

Hi my vm connect app won't connect to hub 4 I've cleared cache tried uninstalling reinstalling nothing works



VM Connect App

For the VM Connect app to work the phone needs to be connected to a Router mode Hub via WiFi and VPNs must be disabled ( i.e. all forms of Apple’s Private Browsing tools / NordVPN and the like must be off )

If you have reinstalled the VM Connect app and it still does not find the Hub, the VM back end systems are often the cause,  just try again in a few days.

Don’t reboot the Hub it is not the reason for the lack of connection.

Until the VM Connect app works manage the Hub at

This has been going on for months haven't got a vpn my phone connects to the hub but the app won't connect 

Hi @Bud12324135 

We're sorry to hear you're having an issue with the Connect App recognising your Hub.

The first thing to be aware of is you need to be connected to your Home Wi-Fi in order for the app to connect to the Hub. It won't allow the connection if you're on a different Wi-Fi network, Guest network on your own Wi-Fi, VPN, or mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:

For your Apple device, if you're on iOS 15 then you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.

If you're on iOS 16 then just delete the app from your device, restart the handset, and then re-download the Connect App.

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache.

If this also fails then we currently have a known error with some of the data in our systems that's causing the app to not recognise the Hub in a minority of instances. We're already investigating this as a high priority.
Pop back and keep us posted.


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

ive done all that nothing virgin media is useless allways something wrong customer service is a joke 

Manage the hub via its menu it is so much easier that trying to use the badly broken VM Connect app.