Showing results for 
Search instead for 
Did you mean: 

Connect app showing wrong SSID

Tuning in

I have just upgraded my Hub from a 3 to a 5 and although the virgin media connect app has picked up my my new router it is still showing my old SSID and I can't home scan as it's asking me to connect to that network. I have done a full reboot of the router and deleted cache and data from the app, deleted the app and rebooted my phone before re installing and logging in but it had not sorted the issue,  has anyone else come accross this? 


Forum Team
Forum Team

Hi Jaypilks

Thanks for posting and welcome to the community. Sorry to hear you're having issues with the Connect App but thanks for letting us know what's been tried currently. As the cache/data has been cleared and a deletion/re-install tried, this is a part of a known issue we're investigating as high priority. 

Hopefully all fixed soon for you.

Kind regards,

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

I’m having the exact same problem and have also tried the same remedies, without success. Is this being resolved?

Hi senormeek,

We're sorry to hear you're having an issue with the Connect App recognising your hub. 

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that: 

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

If this also fails then we currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. We are already investigating this as a high priority. 

Pop back and keep us posted. 


Matt - Forum Team

New around here?

Yep I have the same issue with my app.  I upgraded to the Gig E BB speed and they sent me the hub 5 on the 7th Oct - quick start.  everything was meant to be plug and play and the wifi and tv and pod worked fine but I had no phone line.  completely dead.  Tech came out the following Monday and swapped the coaxs, HUB 5 and run tests from the street cabinnet to my house and advised not a hardware issue, its a configuration issue, 11 days later i.e. today they finally fixed the issue.  11 days with no phone line 😞


now I cant share my SSID password as the app thinks its connected to my old hub SSID and I've tried everything that was suggested below but still showing old SSID thus cant even scan for any blackspots in my house.  GREAT!!!! 😞



HI Gypy, thanks for the message and sorry to hear that you are having issues with the SSID, can you perform a pin hole reset to see if you are now able to connect the connect app and the hub together? Are you still having this issue since posting. Have you tried logging into the hub directly here - Chris. 

Hi Chris_W1

Thanks for your reply. Yes I have tried all that but to no success. The app sees my hub and lists the devices connected to it. The issue is with the share wifi pwd part of the app. Its showing my old SSID.

tried everything from reset cache of the app on my phone to uninstalling and reinstalling the app but to no success.

Hi @Gypy thanks for your reply, I do apologise for this.

As previously advised, as these troubleshooting steps haven't worked we are aware of this as an issue affecting the Connect App at the moment unfortunately.

However, we're doing our best to resolve this ASAP and as soon as we've fixed this we'll be sure to let you know.

Many thanks


Any update on this yet?

On our wavelength

Hi Jay Pilks,

I added a message to your post to say I had the exact same problem with my app now I have upgraded from hub 3 to hub 5.

They have obviously removed my messages chasing this up from your post to make it appear less of an issue which is not very reassuring. This forum is much more helpful when customers can support each others issues.

I told them I had reset the data in the app. Uninstalled and reinstalled, rebooted the hub and the WiFi pod, spent over an hour on the phone with no resolution.

All they have done so far is ask if my problem is that I have messed it up myself by renaming/splitting the 2.4/5ghz frequencies (which I didn't know I could do and haven't attempted) and ask if I know how to do what I've already told them I've done! (Reset, reboot etc).

If this is a "known fault" they don't seem to be getting anywhere investigating it if it's taken weeks already and they're still fobbing us off 😞

Here's hoping we get a useful response at some point.

... For reference, I would prefer my response to remain associated with JayPilks' post... In order to monitor any updates we may both find helpful.