Showing results for 
Search instead for 
Did you mean: 

Cant use connect app

Joining in

Hi downloaded the virgin connect app and its intermittent in finding my hub 3,I have deleted app and re installed it but it still says error can't find hub


Forum Team
Forum Team

Hi Smurf_smith,

Thanks for your Post on the forums, I am sorry you're having issues connecting the Connect App to your Hub. 

Thanks for reinstalling the app to fix it, as this didn't work I have another step for you. 

If you go into your phone's connections, locate the Hub name within your WIFI settings and click "forget SSID". 

Once done this please reboot your device and Hub, then connect to the Hub's WIFI again via the password. 

Once connected, retry the Connect App and let me know whether this works. 



Myself and a few others are having the same experience with the app. There are a few other threads to this effect.

I have tried doing what was suggested in the previous test but without success.

I have a Hub 5 which was working with the Connect app until a few days ago, when I think that there was an update to the app.


I started my own thread about this in the hopes you would help get it sorted. 

The app was working a few days ago, then suddenly stopped connecting. 

Have rebooted, installed app again, disconnected and connected again. 

nothing has worked.