Showing results for 
Search instead for 
Did you mean: 

Broadband - Wi-Fi

Joining in


This is more of a rant. We returned to Virgin after many years and bad experience but had hoped things had improved.

Having been assured that the only charge would be £35 and confirmed that a new feed would be required from the street, surprise, surprise on the day of the day of installation the engineer came and said "You have no cable to the house, I've only come to install in the house!!!" Fortunately, she took a feed off the neighbour and we shared their feed for about a month but it was about a week and a second visit from an engineer before we got the 200MB.

That was in May last year and all was good apart from the extra £55 installation charge which I never got a response from other than "we will look into it" until December when we started getting issue with the Wi-Fi. But nothing major so we accepted it. Come January things got noticeably worse. Speed test showed that the speed would vary form 270-4MB while the test was being carried out. Then we would loose ALL Wi-Fi so I phoned to report an issue again and again. 2 Engineer visits later and we are still having issues, 3 drop outs in an hour so far this morning. I am getting extream grief from my partner and family, "why did we move 70MB from our old supplier is far better than northing or anything we are getting at the moment".

I have made 2 complaints so far but when I check on my account nothing is show, possibly as I made them while on the phone to support but I don't hold out much hope. All I want is a reliable service that I paying for is that too much to ask?

The idea of phoning up support to report I'm still having issues fills me with dread but I suppose I will have to but I will wait in the hope that it will resolve it's self and save my self from the grief.

The sad thing is that the Engineers and most of the phone support has been good, pity that does not lead to a good reliable service.


Trouble shooter

48 Mb/s for the laptop via WiFi is quite typical for an 802.11n connection on 2.4Ghz.

Indeed the Ethernet connection should give a higher connection speed.

Suspect what has happened is the WiFi adaptor has been used and not the network cable.

Try to disable laptops WiFi  & retest. Some laptop have Flight Mode buttons, with the network cable connection one would expect a decent improvement.


No, the Ethernet cable is plugged directly into the hub which is less then 1m away from the Hub and is less than 2m away via Wi-Fi plus no adapter or signal booster. Just done a speed test again via Wi-Fi on the same laptop and is now reaching speeds of 190-250MB. May be the issue is sorted but I want hold my breath as I have been here before, like yesterday and every day for the past few weeks even when the only person using the broadband is just me so it should not be effecting the down load speed.

Thanks for the update Red63, monitor it going forward and let us know if you need us further 🙂




I had hoped that my Wi-Fi issues had been resolved after the visit from an engineer on Saturday after he removed some signal booster installed during installation. Although it has improved, the speed is far from stable downloading emails is so slow taking minutes just to load the text and 5 to 10 minutes if it contains pictures. Some sites are won't even load as they time out due to slow connection (usually with a notice about internet connection). My wife is a school teacher and does a lot of prep work in the evenings but is still having to use her mobile as a hot spot because the internet is so poor.

Just phoned customer services again, who insist that the only way they can help me is to send me a booster which will take 14 days to arrive. A few days I could accept but 14 is a joke especially as a signal booster was one of the items removed by the engineer. And then, if that does not work they will send a new Hub but my calculation that will be more than 30 days which is when I can cancel. So in 14 days, if the booster does not solve the problem I will be cancelling and not wait for the Hub as I am fed up being given the run around.

I have made a number of formal complaints but that seems a waste of time as I have yet t get a single response.


Still having issues with the W-Fi, down to about 5MB at times. Tried to run "Samknows" speed test but surprise, surprise it could not start the test as it kept failing but did suggest I contact my provider. I also tried Uswitch and their test suggested I had a download speed of less than 5MB but an upload speed of over 300MB. Took 5 minutes just to load YouTube before even loading a file.

Will Virgin ever provide the service I'm paying for or have Tech assistance that can work beyond the screen instructions and actually listen to the customer. I left wondering if the signal booster will arrive in about 10 days let alone if it is going to resolve my problems.

Hello Red63.

Thanks for your post. 
Sorry to hear this is still ongoing.
I can look into the Pods and replacement hub for you if you like?
If you don't mind, I will need to send you a private message to pass security. 
If you can check the purple envelope top right of your screen that would be great. 


Hi Gareth

I have been advised that an issue with the broadband in the area has been identified, which is should be resolved by the 10th

I have replied as requested


Hi Gareth

It has been under a week and things have improved. The ethernet speed is now around the 260MB, 5G WiFi is around 250MB most of the time but the 2G WiFi is only about 50-80MB at it's best and that's within less than 1m of the hub.

Hi Gareth

I have a question, 2G is still slow, 5G is giving a speed of 260MB + but connection via Ethernet is only 196MB. How can 5G give a greater speed than Ethernet?

Hi Red63, thanks for the message and welcome back to the forums. 

I have looked at the area and can see that there is an outage. 

The fault reference number is F010562669  and this is estimated to be resolved on the 28th March. 

This will cause the services to be intermittent and we will aim to have this resolved as soon as we can. 

Kind regards, Chris.