Menu
Reply
Martin83
  • 2
  • 0
  • 0
Joining in
141 Views
Message 1 of 4
Flag for a moderator

500Mb BB you just can’t use as Wi-Fi is so bad!

I’ve been with virgin for 8 months now and nothing works unless connected to via Ethernet cable. We’ve upgraded the router, followed all the really basic steps on the help pages and you can directly in front of it with an iPhone and get no signal. 

We’ve had to hardwire every room to support 1 device per child and even with the main devices hardwired non of our less data heavy devices function consistently. 

Anyone else in the same boat? Wi-Fi that is just non existent? 

It’s my first time posting in here so keen to get a better understanding if this is a re-occurring problem or if Virgin even attempt to support these issues? My interactions so far are really poor but they seem to be all over making you aware your direct debit is due. 

At this point I’m considering leaving and accepting slower broadband everyone can use over fast broadband that doesn’t work! 

Tags (1)
0 Kudos
Reply
Martin83
  • 2
  • 0
  • 0
Joining in
132 Views
Message 2 of 4
Flag for a moderator

Wifi that just doesn’t work

I’ve been with virgin for 8 months now and nothing works unless connected to via Ethernet cable. We’ve upgraded the router, followed all the really basic steps on the help pages and you can directly in front of it with an iPhone and get no signal. 

We’ve had to hardwire every room to support 1 device per child and even with the main devices hardwired non of our less data heavy devices function consistently. 

Anyone else in the same boat? Wi-Fi that is just non existent? 

It’s my first time posting in here so keen to get a better understanding if this is a re-occurring problem or if Virgin even attempt to support these issues? My interactions so far are really poor but they seem to be all over making you aware your direct debit is due. 

At this point I’m considering leaving and accepting slower broadband everyone can use over fast broadband that doesn’t work! 

Tags (2)
0 Kudos
Reply
Tudor
  • 12.15K
  • 937
  • 2.41K
Very Insightful Person
Very Insightful Person
127 Views
Message 3 of 4
Flag for a moderator

Re: 500Mb BB you just can’t use as Wi-Fi is so bad!

Most ISPs networking equipment is not very good on WiFi and VM from all reports is at the bottom of the table. I have never ever run any of the VM hubs in router mode always in modem mode with my own networking equipment. This I believe is the best way forward. There are lots of posts on the board recommending the equipment you could use.


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
0 Kudos
Reply
japitts
  • 18.61K
  • 2.42K
  • 4.25K
Very Insightful Person
Very Insightful Person
122 Views
Message 4 of 4
Flag for a moderator

Re: 500Mb BB you just can’t use as Wi-Fi is so bad!

I see Tudor has just beaten me to the obvious comment. Others may be along to give advice on tweaking various wireless settings and suchlike, but... the free router VM supply is a basic model and most aren't famed for their wireless capabilities.

Putting the free router into modem mode and supplying your own wireless kit is a good investment in the long-term. It also means that, should you change broadband provider in the future, your router belongs to you.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply