Showing results for 
Search instead for 
Did you mean: 

1gb broadband upgrade no wifi pods

Joining in

got 1gb broadband last week

but no wifi pods sent with order

have tried several times to order  x2

but getting no where with vm help req


Alessandro Volta

You are lucky. They’ll give you nothing but grief!

But do let us kniw how you get on when you finally get them. Unless I’m mistaken, you’ll get one to start with and if you need another, round the loop you go. 


Seph - ( DEFROCKED - My advice is at your risk)

Joining in

i upgraded to 1gb last week self install , all went smoothly, there were no wifi pods in box,and i need x2 , ive tried on several occasions now to order through via phone calls and not getting anywhere with them,all they say is get app and order through that, app dont see my hub when i walk out the room it is in, i could really do with a mod picking this one up, pls pls pls



Very Insightful Person
Very Insightful Person

WiFi pods are available with your plan, but they are not automatically provided. You must request then, if needed, and then only one at a time with I believe a week between requests.

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

What @Tudor says