Showing results for 
Search instead for 
Did you mean: 

1Gig connection now only 700Mbps? (But upload speed has increased?)

Up to speed

My wired connection has always (mostly) showed over 900Mbps up until a couple of weeks ago, it now only shows between 500 and 700Mbps after breifly spiking to 800Mbps. The drop is showing across all devices (wired and wireless) and is also evident right out of the back of the router by using a USB-C Ethernet adapter for my phone so I can plug it right into a port on the router. I've tried resetting and rebooting etc and it's just the same.

Strangely at around the same time my download speed dropped I've noticed my upload speed increase, it always used to be around 52Mbps and now it's around 105Mbps. Is this an intentional increase in upload speeds at VM's end and if so, has it somehow affected the download speeds?

Maybe worth noting that I've been using an ASUS router with my VM hub with no issue since around September '22 because the VM router can't even get a wireless signal across the room it's in (12ft), like literally no WiFi let alone any other room in house. I've had zero issues since fitting the ASUS and download speeds remained high all around the house up until the recent drop in DL and increase in UL so I'm not entertaining the idea that the ASUS is in any way shape or form responsible for the recent changes.


Trouble shooter

Regarding upload:

Have you tried the integrated speed test within the Asus router?


Joining in

I personally would say that no equipment is at fault but when doing speed tests you need to take into consideration the traffic on the network including traffic to the speed test servers, I personally experience the same quite often.

a few things that help are do regular reboots of your modem / router equipment plus also clear all cache and browsing history etc in your web browsers as this can cause issues with speed.

try testing with different browsers as they all perform differntly and try testing to different servers at different times of the day.


I can't seem to find the speed test within my ASUS router currently. 

The issue is present across all devices both wired and wireless and the router automatically reboots once a week. I know speeds will vary due to many things which is why I always do my tests on a powerful gaming PC that has a wired connection, the results there are usually the same as when I plug my phone directly into the router via a USB-C Ethernet adapter. This rules out all other devices. On the wired PC and the phone I've always gotten 900+Mbps no matter what time of day up until recently where it's suddenly dropped and consistently stayed low across all devices. 

Up to speed

When I joined VM they were the only fibre providers in my area but now CityFibre (who seem to be a fibre broker of sorts) have dug up the road and installed their own cable so they sende letters once a week begging me to join so I'm actually getting tempted now.

Which model of Asus router?

It should be under Adaptive QOS / Internet Speed.

Found it thanks, I was initially looking for it in the Routers Android app and it wasn't there, the app has a lot of features so I assumed it would be there. Logged into the router directly from my PC and found it quick enough. 

Sods law though the connection speed seems ok today (no changes my end), it's hovering around 906Mbps Download and 105Mbps Upload which is mirrored in other tests on other devices today. 

Next time my speed drops I'll check the speed test on the router as well then so good shout, thanks.

The router is an ASUS RT-AX55 and is way better at shooting WiFi all around my house than the VM Hub which can't even get 2.4Ghz 12ft in the same room and the 5Ghz won't even show up when searching for it right next to the hub because it's so weak. The ASUS gets WiFi all over my house (4 bed) upstairs, downstairs, in the conservatory on the back of my house in the garage on the front of the house and down the end of my driveway, only place it can't get to is my back garden but I guess some kind of range extender mounted in the conservatory would solve that problem.