Showing results for 
Search instead for 
Did you mean: 

Need help with Billing

Tuning in

Hi, Since signing up to Virgin, I can't access anything in the virgin media app, when I click billing, then make a payment it says I owe £0, when I click anything else it just takes me back to the home page, my direct debit wasn't taked this month, I've just received my next bill with a late payment charge via email, when I click view bill I get a blank Internet page, same when I click Pay bill.

I raised this with an agent in India when I had first signed up but it didn't get resolved, I've tried reinstalling the app, makes no difference, it used to say "this is a secondary account" doesn't even say that anymore so here I am, unable to pay, no DD being taken, getting hit with late payment charges for a bill I can't even access, my very first bill was sent to me by the agent in India, the last 2 I haven't been able to access.

I also raised a complaint and got a stupid response back which didn't resolve the issue at all, in fact it just went off on a tangent like it was 2 lines written then a template copied.

I can see the direct debit is set up correctly in my online banking but Virgin havent tried to collect the payment.

From what I can see, whoever set the account up, messed it up as initially they took a payment from my partners bank which was attached to their old Virgin account and I had to get that changed, since then, no payments have been taken, complain not dealt with, Indian agent could not fix it and I'm currently unable to access or pay my bill.

Anybody got any ideas how I will get this resolved without calling and getting through to India as that is way too painful and a waste of time anyway.

Thanks in advance guys


Thanks for coming back to me via our private messaging function @Maxim104, and I'm pleased that this has now been resolved.

Do feel free to report back to our Community Forums, if there are any new issues with the services.

Kindest regards,


My issue has now been resolved, thanks for tge offers to help guys and if it was one of you who fixed it, thanks very much