Showing results for 
Search instead for 
Did you mean: 

DEF01 ERROR registering new account

Tuning in


I have bought a new virgin media package for the 1st time going onto a week now and i cannot get logged in or even register to view my account bill nothing . My experience as a 1st time buter has not been great as it almost took 3 days to get my name changed ( well so i was told over the phone but cant check yet ) as my surname was grosely mis spelled but apart from that i need to log in to the account im paying for . I have tried my pc . My mobile my tablet both app and web browsers and even from work i just keep geting the DEF01 error or try again later . Im not sure if in the past my email address was connected to a virgin media account  or not but could be possible but i need this sorted asap i dont want to cancel this before i have even started over something that should have been so simple to fix.


Kind regards




Thank you for the link but it is still not working i still get the DEF01 error message



Forum Team (Retired)
Forum Team (Retired)

Hi @Bigsluyky

Welcome back to our Community Help Forum 🙂

Thank you for making this post regarding your My Virgin Media account, I'm sorry to hear you are experiencing issues with registering for this. Are you able to try using a different email address to register for My Virgin Media? If so, can you try this and let me know if it works. Can you also try clearing your cache and deleting your cookies before trying to register again?

Kind regards,


Hi Serena

As per instruction by Virgin media it states when registering your new account you must use the email account used originally used to set up the new account but i did try my gmail account also and still the same issue. And as previously mentioned i have used different browsers . Apps and also cleared all cookies and cache the problem isnt at my end it is at Virgin media end this is now a week thats passed and it is becomming very fustrating . I am currently waiting on my new home kit arriving today whixh i cannot view as cannot log in and i am unable to view my bill or any details im afraid further delay to get this fixed will result in me leaving VM before i even get plugged in.




Thanks for the response the Bigsluyky,

To further investigate this I've dropped you a PM, you'll find this within the purple envelope icon.