Showing results for 
Search instead for 
Did you mean: 

O2 Priority Error

On our wavelength

Trying to register for O2 priority using the O2 priority app and the virgin media log in details and keep getting the below error:

"Oops, something went wrong"

I have contacted O2 who say I need to contact Virgin, however, its easier to find unicorn poo than contact virgin media.

Anyone know how to resolve this issue?


Forum Team
Forum Team

Hey GaryGorilla, thank you for reaching out and I am sorry you are having some issues signing up to the O2 priority app.

We're aware that some of our customers are experiencing problems whilst trying to log into the O2 Priority App. Signing into the web version has worked for some but not for others.

We have spoken to our O2 colleagues who are aware of it and we hope to get it resolved as soon as we can.


Matt - Forum Team

New around here?


Is there any update on the o2 priority login issue? I have had the same issue for some time now.


Hi @Resubmit0205, thanks for your post here and I'm sorry you're still having issues with the O2 app.

Are you able to kindly confirm the make and model of your handset?

Can you also try resetting your My Virgin Media password, then uninstalling the O2 Priority app, installing this and come back to us again?

Many thanks


OnePlus 10 pro

I've tried resetting my password, another user suggested this.

I've also reset the app and tried using

A number of users on money saving expert are also having the same issue.

Hi @Resubmit0205 thanks for your reply here, much appreciated.

All understood - we appreciate this is an issue for quite a few customers at the moment.

As mentioned, we are aware of this and we're hoping for things to be fixed ASAP!

Many thanks


Any updates on this please?

Hi @Resubmit0205


Thanks for your post!


Have you tried reinstalling the app and attempting to register/login again after this?



Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Yes it doesn't work.

I have also tried on

Hi @Resubmit0205


Thanks for your response


Can you confirm if you're using iOS or Android? Are you able to log into the MyVM app fine?



Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs