Showing results for 
Search instead for 
Did you mean: 

Unable to Manage my account online

Joining in

I am unable to manage my account online.  When I type into the address bar in edge I get:

Bad Request

Your browser sent a request that this server could not understand.
Size of a request header field exceeds server limit.

If I do the same in an "In Private" browser session I get taken to the virgin media page.  If I sign in I immediately get prompted to "Complete your profile" even though I've done this many times already.  If I enter the details and click confirm I get "Oops, we've ran into a problem.
Wait a minute and try again. If this doesn't work, please come back later. (Code: DEF01)" and there is no way to get off the "Complete your Profile" page.

I can click on the link in my billing email and that takes me to a page where it looks like I might be able to manage the account and where I can see some information, but a lot of the links are broken - just sending me to the "Bad Request" message above. 

Note that I have another account for a different property with Virgin Media that works and the site looks COMPLETELY different when managing that account.

Note that I have been trying to manage this account for about 9 months so far and this is as good as I have had it so far!!  Trying to contact virgin media about it is a complete waste of time with HOURS spent talking to bots and clueless people who can only do what I have already tried.  Please can someone help!!??  It's not good enough from Virgin Media 😞



Forum Team
Forum Team

Hi billyboyD,

Thanks for posting on our community forums. We're sorry to hear that you're experiencing issues when trying to access your account online using

We have tried the link from our end and have no issues accessing our website. 

Can we ask if you're able to use a different web browser and device to log in?

Also, deleting all cookies/caches and history may also help.

Please try the above first and come back to us if you still require assistance. 

Kind regards Jodi. 

Obviously there is an issue with cookies, which is why I get further with a private session in edge.

Using chrome is exactly the same as using a private session in edge (because I don't have the dodgy cookies), but obviously that doesn;t help much - I still get in the perpetual "Complete Your Profile" loop as explained in the first post...

By randomly clicking stuff I managed to get out of the loop and access My Virgin Media briefly (using Chrome).  I've tried to change my phone package and update my direct debit which are the 2 things I need to do - I am not sure if either was successful as now all I am getting are errors whenever I click on a link and I've not received any email confirmations.  Its AWFUL.

And before you ask - there is nothing wrong with my wifi or broadband.  Everything works - except "My Virgin Media"!

Thanks for coming back to us billyboyD.

We can certainly check if your request has been processed regarding your DD and package change for you.

Can we ask if you're able to access your online account with no issue through our Virgin Media app?

I will pop you over a private chat to make sure your changes have been implemented.

Click on the purple envelope to accept the chat.

Kind regards Jodi.