Menu
Reply
Highlighted
  • 4
  • 0
  • 0
Joining in
1,138 Views
Message 1 of 8
Flag for a moderator

FIFA 20 online game modes not working

Hi,

I am having issues with connecting to any online game modes in FIFA 20 on PS4. Everything was working fine up until last week. The connection to the EA servers is fine and connects as expected and I can connect to FUT but when I try to access Rivals in FUT, or seasons, or any other online game mode, a brief message box flashes up when attempting to connect saying there was an issue with the request and I'm returned to the menu I came from.

I have a wired ethernet connection from my SH3 to my PS4 and there are no internet connection issues in general with any other game or streaming service. I have tried switching to WiFi and have also tried port forwarding the required ports for FIFA 20 online gaming and neither has worked. 

I am able to to access online game modes when switching the PS4 to use my hot spotted mobile connection and I also encounter no issues when logging in from other locations. This rules out an issue with my EA account and strongly suggests it's an issue with my internet connection or the SH3.

Any help would be greatly appreciated.

Many thanks!

 

 

 

0 Kudos
Reply
Highlighted
  • 3.16K
  • 565
  • 804
Very Insightful Person
Very Insightful Person
1,127 Views
Message 2 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working

Hello

Very strange, it could be the child safe is blocking you -

Can you login too your virginmedia account at https://my.virginmedia.com/home/index

Once logged in goto "My Apps" top center of the screen and click on "Web Safe", if Child Safe is on, click the slider until it greys out then click "Apply".

Once it is off turn off your games console and back on, that should resolve your issue, if it doesn't please get back to us.

Regards Mike

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Highlighted
  • 4
  • 0
  • 0
Joining in
1,120 Views
Message 3 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working

Thanks for the response Mike, just checked and the child safe setting was already turned off.

It is really strange, had no issues at all until the past few days, nothing had been changed on the PS4 or the Super Hub.

I tried reinstalling the game and also factory reset the Hub but to no avail. I put it down to the EA servers at first but nobody else seemed to be reporting the same issue. I have friends who can login and play online using my account in other locations with absolutely no problem. It's certainly a puzzler!

Cheers,

Daniel

0 Kudos
Reply
Highlighted
  • 5.02K
  • 571
  • 1.68K
Very Insightful Person
Very Insightful Person
1,078 Views
Message 4 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working

Hi Daniel

I'd suggest a test with the Hub in modem mode and just the PS4 connected in order to rule out any weird routing issues with the router part of the hub.

______________________
Scott

My setup: V6 TV box, M350 Fibre broadband with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

 

Mark as Helpful Answer if I've helped

Highlighted
  • 4
  • 0
  • 0
Joining in
1,070 Views
Message 5 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working

Thanks Scott, just tested with the hub in modem mode and it worked! Any suggestions on what could be the issue when in router mode?

0 Kudos
Reply
Highlighted
  • 5.02K
  • 571
  • 1.68K
Very Insightful Person
Very Insightful Person
1,064 Views
Message 6 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working


@useenmelately wrote:

Thanks Scott, just tested with the hub in modem mode and it worked! Any suggestions on what could be the issue when in router mode?


Best guess is that something isn't making it through to one of the ports on the PS4 to allow it to talk to the EA servers properly.  In modem mode there is no routing and all data on all ports goes straight to the PS4, in router mode the same data might be going AWOL.  The hub should be using UPNP to correctly route traffic but the VM hubs (especially the Hub 3) have a history of not always doing it right.

Long term solutions are:

1. Try again with the port forwarding and see if you missed any ports last time. Make sure the firewall option is ticked as the port forwarding is handled by the firewall in the Hub 3.

2. Buy a third party wireless router and keep the Hub in modem mode.  Most third party routers handle UPNP correctly and so have no need for port forwarding.  The Netgear router I use has no port forwarding and I can game on PS3 and PS4 without any issues.

______________________
Scott

My setup: V6 TV box, M350 Fibre broadband with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

 

Mark as Helpful Answer if I've helped

Highlighted
  • 4
  • 0
  • 0
Joining in
1,056 Views
Message 7 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working

Thanks for the details, I'll try the port forwarding again and see if that does the trick. If not it looks like I'll be investing in a new router! 

Thanks again for the detailed response, much appreciated.

0 Kudos
Reply
Highlighted
  • 8
  • 0
  • 0
Tuning in
467 Views
Message 8 of 8
Flag for a moderator

Re: FIFA 20 online game modes not working

I have the same issue but I am using an Xbox.  I start up FIFA20 and start Ultimate Team and after a longer wait than usual it starts and crashes the game immediately (the music stops and the game doesn't respond).  Child Safe is turned off on my account but I am in Modem mode as I have a Google WIFI Mesh setup. I first noticed this on Friday morning but I'm not sure when it started as I haven't tried to play the game all week. I'm certainly not going to buy a new router or change my existing setup. To me it's obvious either EA or Virgin Media have changed something and need to back out whatever is causing this issue. 

0 Kudos
Reply