Showing results for 
Search instead for 
Did you mean: 

Netflix included in my package not activating

Joining in

I have had my package since 19th July, and I am still not able to activate my6 Netflix account, I have spent hours on the phone spoke to 2 manager 1 call Yann who promised to call me back after raising the 7th ticket with the support team for Netflix and the virgin IT team, still no call and still not working.  Ive had 15 whatsapp conversations with people saying they will raise a ticket have to wait 5 days and still nothing PLEEEEEASEEEEE CAN SOMEONE HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Alessandro Volta

I had a package upgrade done yesterday which includes Netflix, all I had to do was launch the app on my 360 and was presented with my email address for account setup, accepted that email address, input my password, declined the option to pay £5pm to upgrade from Netflix Standard, and I then had access to Netflix. My hub was in router mode as I have a recollection that a setup some years ago didn't work in modem mode.

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

Thanks for the reply, this has not happened as everything I try to activate I get the error message something went wrong

Hi kellyp2305,

Thank you for your post and welcome to the community.

I'm very sorry for the issues you've had with your Netflix service. 

I am happy to take a look into this. 

I will private message you now to confirm your details.