Menu
Reply
Domwilko
  • 35
  • 0
  • 5
On our wavelength
230 Views
Message 1 of 5
Flag for a moderator

Tivo STB Network Setting - Error C138

I have 2 Tivo Boxes in my house. One is a legacy (large) Tivo box and the other is a Tivo 6 box. I wanted to watch some of the recordings on my Tivo 6 box on my legacy Tivo box, so I decided to hook the legacy Tivo box up to my home network, which I've had configured for years on a 10.200.xxx.xxx /24 subnet. The Tivo 6 box has been happily using a 10.200.xxx.xxx IP address since it was installed years ago and there has never been an issue. However, the legacy Tivo box won't allow me to configure the device with a 10.200.xxx.xxx IP address. I get an error message C138 saying that the IP address is not in a permitted range and suggests going to virginmedia.com/tvcode for more information. The error code C138 isn't even listed and there is no further information!

So, what IP address ranges are permitted? From what I understand the Tivo boxes need to be on the same subnet to be able to work together, so I can't even change the range to a 192.168.xxx.xxx range and route between the two networks as apparently that won't work.

It seems stupid that the Tivo 6 box will happily work with a 10.200.xxx.xxx IP address, but the legacy Tivo box won't. This makes the two boxes incompatible and I don't see why I should change the whole of my home network IP address schema just to get the Tivo boxes working together.

Perhaps Virgin Media would like to replace my legacy Tivo box with a new Tivo 6 or Tivo 360 box so that I have have the functionality to play my recording across boxes?

Any advice on how to resolve this without having to re-address the whole of my home network?

Tags (2)
0 Kudos
japitts
  • 12.03K
  • 1.67K
  • 2.58K
Very Insightful Person
Very Insightful Person
199 Views
Message 2 of 5
Flag for a moderator

Re: Tivo STB Network Setting - Error C138

Others may be able to pick up the networking angle in more detail, but by means of covering the basics...

The same internet connection that your V6 uses for VOD etc, is also used for streaming. The TiVo needs a separate Ethernet cable to the same router as used by your V6 - in other words, the same subnet.

I'm going to assume you're using the VM Superhub in modem mode, with your own router? As long as both boxes are using the same subnet, I don't see any reason for MRS (Multi-room-streaming) to not work.

As regards a box-swap, if you've had your current package more than a year and you're out-of-contract, there's nothing stopping you from calling VM and asking about swapping the boxes in return for a new package and new 12/18month contract.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Domwilko
  • 35
  • 0
  • 5
On our wavelength
197 Views
Message 3 of 5
Flag for a moderator

Re: Tivo STB Network Setting - Error C138

You are correct, I'm using my Superhub in Cable Modem mode, due to it's lack of an sort of advanced functionality. Being a Network Consultant by trade, I am using my own hardware firewall, switching and access points behind the Cable Modem. The V6 box works perfectly fine behind this setup and I've never had any issues with it and it's connection to 'my' Wifi access point using a 10.200.xxx.xxx IP address has never been an issue. I'm trying to put the legacy Tivo box on the same subnet; I'm basically using a wireless bridge to connect it in to the same subnet from downstairs. The Wifi bridge works perfectly (as I have other devices connected to it), the problem is that the legacy Tivo box just will not allow you to use a 10.200.xxx.xxx IP address. I've tried assigning it by both DHCP and Static assignment, but it just gives me an error C138, but there is no further information on this error. I can't even find any info as to what 'are' permitted IP address ranges.
I've now requested a V6 box swap, hopefully they will honour it as there doesn't seem to be any solution for this problem.

0 Kudos
japitts
  • 12.03K
  • 1.67K
  • 2.58K
Very Insightful Person
Very Insightful Person
190 Views
Message 4 of 5
Flag for a moderator

Re: Tivo STB Network Setting - Error C138

I've no issue with the lack of router functionality on the VM hubs, many users in the broadband/network section of this board do very similar to what you've done, and I myself use modem mode with my V6 and separate router.

Multi-room-streaming using your own router, is not a scenario I've dealt with much, and where my obvious suggestion would be to use the same subnet..

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Domwilko
  • 35
  • 0
  • 5
On our wavelength
187 Views
Message 5 of 5
Flag for a moderator

Re: Tivo STB Network Setting - Error C138

That is the very issue. I'm trying to use the same subnet (10.200.xxx.xxx /24) as that is what the whole of you home network is on. I'm trying to add the legacy TIVO box to this same subnet, but it won't let me. It just doesn't want to support the use of a 10.200.xxx.xxx IP address. It just seems odd when the TIVO 6 box does.

0 Kudos