Menu
Reply
ec1992
  • 4
  • 0
  • 1
Tuning in
304 Views
Message 1 of 7
Flag for a moderator

Box slow and apps not working

I've had my Virgin TiVo box for 4 years now and it has become very very slow. I can take up to 10 seconds for the picture to come back when just changing channels.

I now also have the issue that I am unable to use the catch up apps. Even though I am logged into the ITV, All4 & Prime Video accounts, it plays the adverts, but then just says the service is temporarily unavailable. This has been happening for over a month.

Is it possible we need a new box? Can't get hold of anyone at Virgin to ask, yet still having to pay my monthly TV service bill.

0 Kudos
japitts
  • 11.97K
  • 1.66K
  • 2.56K
Very Insightful Person
Very Insightful Person
299 Views
Message 2 of 7
Flag for a moderator

Re: Box slow and apps not working

Hiya,

Firstly do you have a TiVo or a V6? You've mentioned TiVo but that box doesn't have the Amazon or All-4 apps so let's check now... if you're not sure, this page should tell you.

Re your problem with CatchUp apps, I'm going to guess you're watching on a 4K TV and this now needs HDCP 2.2 support, which some older TV's don't necessarily have on all HDMI ports.

Have you tried all your TV's HDMI ports? If you're still stuck, post the exact make & model and I'm sure someone will look up the manual for you.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
ec1992
  • 4
  • 0
  • 1
Tuning in
289 Views
Message 3 of 7
Flag for a moderator

Re: Box slow and apps not working

Thanks. I think it’s the V6 box based on that link. 

We have no issues watching anything in HD, Netflix works absolutely fine, as do all the HD channels. We never used to have an issue with the catch up service, and iplayer works fine. This last month it’s been the ITV and All4 that are the issue, and it’s the same whether it’s through the catch up menu, or via the app itself. 

0 Kudos
japitts
  • 11.97K
  • 1.66K
  • 2.56K
Very Insightful Person
Very Insightful Person
283 Views
Message 4 of 7
Flag for a moderator

Re: Box slow and apps not working

Thought as much, but always good to make sure!

Almost certainly an HDCP 2.2 issue. What's the exact make & model of your TV?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

ec1992
  • 4
  • 0
  • 1
Tuning in
277 Views
Message 5 of 7
Flag for a moderator

Re: Box slow and apps not working

Just swapped round some of our HDMI cables in the back of the TV and success! Thank you so much!

ec1992
  • 4
  • 0
  • 1
Tuning in
226 Views
Message 6 of 7
Flag for a moderator

Re: Box slow and apps not working

Hi, the fix worked for a day or 2 but the picture issue is back. Any help is appreciated. 

The TV is fairly new - Toshiba TV 55T6863DB, purchased November 2018. 

0 Kudos
Lee_R
  • 2.94K
  • 151
  • 279
Forum Team
Forum Team
198 Views
Message 7 of 7
Flag for a moderator

Re: Box slow and apps not working

Hi @ec1992, thanks for posting and welcome to our community.

I am sorry to hear you're having issues with your TiVo box.  I would like to take a closer look at this for you. To enable me to do so, I am going to send you a private message.  Please look out for the purple envelope in the top right of your screen.

Regards


Lee_R

0 Kudos