Showing results for 
Search instead for 
Did you mean: 

V6 can’t open Apps

Tuning in


just had a V6 sent to me to replace my faulty old TiVo box. We installed it ourselves. Channels and recordings are ok. But I cannot open some of the Apps. Netflix is ok.

But can’t open Prime or BBC iplayer. Just spins and goes back to app page. Any ideas? 




Very Insightful Person
Very Insightful Person

The functions you describe use the internet, and your V6 needs a connection to your homehub in order to go online. You mention that Netflix is OK, which would suggest internet connectivity isn't the issue. Can you view OnDemand programmes OK?

If so, have you tried restarting your V6 via Help & Settings > Clear or restart?

When did you install this V6?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

I actually just tried turning it on and off at the back, scarily the welcome screen loomed again but eventually it came on ok and all the apps I need are there. Thanks 

Thank you for your reply Hale, and thanks for updating the thread.

Glad to hear all is working fine 🙂