Menu
Reply
saogan
  • 10
  • 0
  • 5
Tuning in
645 Views
Message 1 of 15
Flag for a moderator

Re: Prime Video not working

Oh no this problem has surfaced on my system yet again!!!!!!  Seems Virgin just can't resolve this recurring issue. Had the exact malfunction about 6 months ago with both Netflix and Amazon Prime access and in the end had to install a new TIVO box which did seem to fix the fault. BUT its back again. 

Followed all the usual advice re boot the box check all the connections blah blah all to no avail. Restarting the box did work only to fail when used again on Amazon and hence the blank screen. Prime and Netflix both work perfectly fine on my laptop, tablet  and smart TV when accessed individually so it is the TIVO box having issues. Perhaps their IT isn't up to the current demand placed on it any more? 

Phoned the Virgin helpline yesterday and spoke to an advisor about it who put me on hold for an hour then cut me off. Some customer service this.

Its about time Virgin Media finally sorted out this aspect and no doubt some customers out there are also suffering this issue. 

0 Kudos
Reply
Revok
  • 11
  • 0
  • 2
Tuning in
637 Views
Message 2 of 15
Flag for a moderator

Re: Prime Video not working

Mine never got resolved - I can access prime through my television, so I've watched it through there since.

 

 

0 Kudos
Reply
amandeep86
  • 1
  • 0
  • 0
Joining in
536 Views
Message 3 of 15
Flag for a moderator

Re: Prime Video not working

Are you still having this issue? As of yesterday (29th Dec), this has happened but only to the box in the kitchen. Our box in the living room and upstairs loads fine and is ok. 

We're having the issue with Prime and Netflix (Ch 204 and 205) where we're able to access the app but as soon as you click to play something, it just stays on a blank/black screen. iPlayer, ITV and All4 are loading content all fine so not sure of the issue. 

I've looked at other threads on this and I am unable to connect the box via ethernet, as it's too far away from a port. Any suggestions from the Virgin Media Team?

Tags (1)
0 Kudos
Reply
Revok
  • 11
  • 0
  • 2
Tuning in
530 Views
Message 4 of 15
Flag for a moderator

Re: Prime Video not working

Netflix is fine on both the channel (ours is 204 or something like that) and the app, but Prime doesn't work either way.

I have a sneaky suspicion it's possibly something to do with the HDMI cable - it might be worth seeing if you can swap one and whether that helps at all........
newapollo
  • 6.46K
  • 1.01K
  • 1.6K
Very Insightful Person
Very Insightful Person
521 Views
Message 5 of 15
Flag for a moderator
Helpful Answer

Re: Prime Video not working

 Have you tried the advice given by Kev_B in the >>> pinned post <<<  ?

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click to mark as a Helpful Answer or use Kudos to say thanks


Revok
  • 11
  • 0
  • 2
Tuning in
451 Views
Message 6 of 15
Flag for a moderator

Re: Prime Video not working

Problem all solved - I tried to watch a streamed movie last night and got a back screen - there was however an error code which I looked up and it was to do with ensuring the box was plugged into a HDCP 2.2. HDMI MHL port on my telly - on my samsung this was port no. 3 on the back of the telly and not no.1 as had been.

End result - swap the HDMI cable into another port at the back and bingo - all working fine now 👍🏻 

jgnotts
  • 30
  • 0
  • 4
On our wavelength
425 Views
Message 7 of 15
Flag for a moderator

Re: Prime Video not working

My lounge box has not had any problems playing Prime content until today. I know it was working OK over Christmas but it won’t work now. 

I can display and search Prime for content and then press Play and it just won’t play anything - come up with a message ‘something went wrong please try again later’

My kitchen box works fine and both boxes are wired via Ethernet. 

The lounge box plays back content on iPlayer OK so I can’t see it being a network issue?

Last week I did connect a soundbar to to the box, so I had a hdmi from the V6 box into the Yamaha soundbar and then another from there into my television. So I wondered if this was the issue so have removed it completely and I still have the issue.

My television is 1080 and the V6 box is set to auto 1080p

 

0 Kudos
Reply
Revok
  • 11
  • 0
  • 2
Tuning in
418 Views
Message 8 of 15
Flag for a moderator

Re: Prime Video not working

try plugging the HDMI cable from the V6 box into another port on the telly - if you can find out which (if any) ports support HDCP2.2 put it into there and see if that works? 

 

0 Kudos
Reply
jgnotts
  • 30
  • 0
  • 4
On our wavelength
415 Views
Message 9 of 15
Flag for a moderator

Re: Prime Video not working

It’s plugged into the same port as it was when it was working at Christmas.

I’ve tried it in the other sockets but it’s just the same. My telly is a 13 year old plasma so isn’t going to have certain hdmi features but the telly in the kitchen is equally as old and that box is working

 

0 Kudos
Reply
jgnotts
  • 30
  • 0
  • 4
On our wavelength
408 Views
Message 10 of 15
Flag for a moderator

Re: Prime Video not working

I did a complete power down of the box and left it unplugged for a couple of minutes before starting it again. 

It now seems to be working OK, so hopefully it will carry on working !

 

0 Kudos
Reply