Menu
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
461 Views
Message 1 of 14
Flag for a moderator

Prime Video not working

We've been trying to watch amazon prime on ch205 - we can access the menu screen with no issues and scroll through the programme choices, however when we click on an individual episode or film these fail to load. 

I've re-registered my prime account via the v6 box, but his hasn't solved the problem. Netflix on ch204 is working fine.

0 Kudos
Reply
Highlighted
  • 8
  • 0
  • 3
Tuning in
394 Views
Message 2 of 14
Flag for a moderator

Re: Prime Video not working

I’m having the same problem although this only started earlier on today. Is yours working again now? Anyone got any ideas?
0 Kudos
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
390 Views
Message 3 of 14
Flag for a moderator

Re: Prime Video not working

Nope although I’ve got a second TiVo box and it works ok on that, having checked . I had to do a factory reset on my tv last week, and I think it’s got something to do with that.......possibly something to do with HDMI? I need to investigate further

0 Kudos
Reply
Highlighted
  • 8
  • 0
  • 3
Tuning in
354 Views
Message 4 of 14
Flag for a moderator

Re: Prime Video not working

It’s working fine on our other box too. But nothing significant happened here that might have disturbed Amazon, it just suddenly stopped working. I watched one episode of a show and then instead of moving directly onto the next the screen just went blank. Netflix and YouTube appear to be fine so I’m flummoxed.

0 Kudos
Reply
Highlighted
  • 2.48K
  • 373
  • 509
Problem sorter
344 Views
Message 5 of 14
Flag for a moderator

Re: Prime Video not working

Have you tried playing Amazon Prime and Netflix from their apps instead of from the channel to see they work from there?
Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali
0 Kudos
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
177 Views
Message 6 of 14
Flag for a moderator

Re: Prime Video not working

Yes they all work fine from apps on our laptops and tablets - I've had a look on the tivo box but couldn't see any apps though. Netflix works fine through the 204 channel. I think it's a HDMI cable issue to be honest - i had to reset the telly recently back to it's factory settings and I think that's what's screwed it up, as I can't get the smarthub application to load either now.

hum

 

0 Kudos
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
165 Views
Message 7 of 14
Flag for a moderator

Re: Prime Video not working

Check the amazon prime app - still not working! 

0 Kudos
Reply
Highlighted
  • 2.17K
  • 89
  • 136
Forum Team
Forum Team
132 Views
Message 8 of 14
Flag for a moderator

Re: Prime Video not working

HI Revok, thanks for the message and we are sorry to hear that you are having issues with the app. Do you have a different HDMI cable to try at all? Chris 

0 Kudos
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
115 Views
Message 9 of 14
Flag for a moderator

Re: Prime Video not working

Tried a new HDMI cable - still no luck!
0 Kudos
Reply
Highlighted
  • 3.22K
  • 135
  • 189
Forum Team
Forum Team
98 Views
Message 10 of 14
Flag for a moderator

Re: Prime Video not working

Thank you for the update Revok.

 

Are you able to follow the below steps to refresh the box and let us know how this goes? 

Home> Help&Settings> Settings> Network> Connect to Virgin Media Service Now

 

If you still have issues following this can you let us know if you've experienced any broadband issues as well as this recently? As the apps are run through the internet so this may be related. 

 

Let us know, Emily.

0 Kudos
Reply