Menu
Reply
MiserableVirgyn
  • 10
  • 0
  • 0
Tuning in
1,363 Views
Message 1 of 11
Flag for a moderator

On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution

About 6-12 months ago my Virgin On Demand services stopped working for no obvious reasons.  "This show is temporarily unavailable"  "Error 603" when attempting to view many on-demand services such as ITV Player of 4 On Demand (note other online services such as Netflix, I-Player are NOT impacted).

After many hours talking to the "experts" at Virgin Media call centre (that gave me a myriad of incorrect advice - including telling me it was because I was using "modem mode"),trying everything including:

Restart Tivo

Restart Hub

Change all cables

Connect direct

Use 1080p mode

Then 4 engineer visits, the fourth engineer in consultation with a top Virgin Media expert (thanks Nigel) finally tracked the issue down to an issue with my Yamaha AV-3060.  When changing the connection it is necessary to restart the TiVo for the new connection to handshake (and either allow or block VOD).

If I connect a V6 or TV360 box to my Yamaha AV-3060 then my 4K UHD Sony Projector then issue 603 occurs.  However, if I connect V6 or TV360 box direct to my 4K UHD Sony Projector then there is no problem.  It is important to note that I need to restart the Tivo box when making this change.

My Yamaha AV-3060 IS capable of Ultra HD 4K/60p and HDR pass-through, all ports are HDCP 2.2 certified (https://www.whathifi.com/yamaha/rx-a3060/review).  I'm using quality cables (the fact that it works when I connect direct to projector demonstrates this)

The dodgey workaround is that if I connect V6 or TV360 box direct to my 4K UHD Sony Projector, restart the Tivo box then VOD works.  If I then connect the cable from Tivo box to Yamaha AV-3060 then projector it all works, that is until the Tivo box is restarted.

This bodge worked for a couple of days but then the V6 box completely packed up - another engineer visit required and a new Tivo box installed - this time a TV360 - but same issue occurs.  (I'm not sure if this workaround cause this Tivo box to fail or if it is just a coincidence.)

I was told that Virgin pushed an update about a year ago (seemingly) the time my issue started that caused this issue.  It was working previously for me.  All my equipment is up to spec and meets VM's requirements (see https://community.virginmedia.com/t5/Virgin-TV-V6/On-demand-not-working-Try-this/td-p/4540232)

So what can we do about this?  It is apparent from here that I am not the only one suffering this loss of service.  Is Virgin going to do anything about this?

0 Kudos
Reply
japitts
  • 18.19K
  • 2.35K
  • 4.16K
Very Insightful Person
Very Insightful Person
1,340 Views
Message 2 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution


@MiserableVirgyn wrote:

This bodge worked for a couple of days but then the V6 box completely packed up - another engineer visit required and a new Tivo box installed - this time a TV360 - but same issue occurs.  (I'm not sure if this workaround cause this Tivo box to fail or if it is just a coincidence.)


This bit's fundamental. A TiVo box runs TiVo software. A V6 box runs TiVo-software. A 360 box runs Horizon software, and is completely different.

If you have converted any of your V6 to 360, they are no longer TiVo boxes but are now 360 boxes. Any TiVo or V6 - runnning TiVo software - will have the TiVo logo in the top-right corner of the menus next to the video preview. If that's not there, you don't have a TiVo.

With all this in mind, which do you currently have?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
MiserableVirgyn
  • 10
  • 0
  • 0
Tuning in
1,305 Views
Message 3 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution

Thank you for the reply.

I had a V6 box, yesterday I was given a new box (was told it was a 360 box) but it is currently running Tivo software, apparently I will receive a new remote in a few days and then can upgrade it to 360.  For now though my 360 box is running Tivo software and VOD is not working here (as was the case on the V6)

 

0 Kudos
Reply
japitts
  • 18.19K
  • 2.35K
  • 4.16K
Very Insightful Person
Very Insightful Person
1,297 Views
Message 4 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution


@MiserableVirgyn wrote:

apparently I will receive a new remote in a few days and then can upgrade it to 360.  For now though my 360 box is running Tivo software and VOD is not working here (as was the case on the V6)


So you currently have a V6 but have asked to migrate to 360.

When your V6 stops being a V6 and becomes a 360, then you will no longer have issues with Error 603. That's because Error 603 is a TiVo-software error and nothing to do with 360.

You may have alternate error codes under 360, for the same problem - but at that point you won't have a TiVo/V6 but will have a 360. FYI you can ask about any 360 issues in the TV-360 forum here 

TiVo & 360 are completely different software platforms.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
MiserableVirgyn
  • 10
  • 0
  • 0
Tuning in
1,280 Views
Message 5 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution

Thank you for the reply. 

OK I'm going to stick with the Tivo software (and not upgrade to 360 - as I prefer the Tivo software, specifically the ability to record shows not yet in the guide)

Now that semantics are out of the way, can anyone help with the original problem:

On demand not working - Error 603 - Tried EVERYTHING - on V6 box:

?

Thank you

0 Kudos
Reply
Gareth_L
  • 9.83K
  • 554
  • 1.1K
Forum Team
Forum Team
1,226 Views
Message 6 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution

Hello MiserableVirgyn

Sorry to hear about On Demand error 
I am more than happy to take a look at this for you 
I will need to send you a private message to pass security 
If you can check the purple envelope top right of your screen that would be great 
Regards     
Gareth_L

0 Kudos
Reply
MiserableVirgyn
  • 10
  • 0
  • 0
Tuning in
1,199 Views
Message 7 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution

Gareth - thank you for arranging an engineer visit - however, he didn't arrive in time.  

I still have the problem and I'm no closer to any solution.  It seems that a visiting engineer would not be able to fix this. 

The last engineer I spoke to suggested I post this on the forums so it seems we are going around in circles.

Can anyone help?

0 Kudos
Reply
Roger_Gooner
  • 7.86K
  • 518
  • 1.48K
Alessandro Volta
1,190 Views
Message 8 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution


@MiserableVirgyn wrote:

Is Virgin going to do anything about this?


VM isn't going to do anything about this as it's not VM's problem. The V6 is made to a specification which enables a direct HDMI connection to a TV, and any handshaking issue with a sound system isn't something VM can solve (except to do a box swap which has been done). Have you tried the Yamaha and Sony forums?

Having said that, what do you mean by "restart the TiVo"? The box should be left on all the time; I have my V6 power saving set to "Always On" and I put it into standby when not watching TV. I also take my TV, AVR and V6 out of standby in that order as I believe that it facilitates handshaking.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG108S 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
Zach_R
  • 3.45K
  • 115
  • 241
Forum Team
Forum Team
1,164 Views
Message 9 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution

Hi @MiserableVirgyn,

Apologies, but would you mind clarifying what you mean when you say that the engineer didn't arrive on time?

Thanks,
 



Zach - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
MiserableVirgyn
  • 10
  • 0
  • 0
Tuning in
1,159 Views
Message 10 of 11
Flag for a moderator

Re: On demand not working - Error 603 - Tried EVERYTHING - found only a "dodgy" solution


@Zach_R wrote:

Hi @MiserableVirgyn,

Apologies, but would you mind clarifying what you mean when you say that the engineer didn't arrive on time?

Thanks,
 


(I said "in time") I received an SMS saying "We're planning on seeing you between 8am and 12pm".  Engineer called at 11.38 to say he was on his way but would be 10-20 minutes.  I had another appointment at 12 so advise that it wouldn't be possible to attend.  We discussed the technical problem on the phone, I explained the issue he said he would get back to me that day but I never heard anything.

The problem remains after 5 engineer appointments and 15+ calls to VM and now forum posts - so really not optimistic this is ever going to be fixed.

0 Kudos
Reply