Menu
Reply
Develle01
  • 2
  • 0
  • 0
Joining in
245 Views
Message 1 of 10
Flag for a moderator

Amazon prime video

Amazon prime video has stopped working. We can get onto the menu screen but when selecting something to watch the screen just goes black!

0 Kudos
Reply
japitts
  • 8.57K
  • 1.2K
  • 1.66K
Very Insightful Person
Very Insightful Person
237 Views
Message 2 of 10
Flag for a moderator

Re: Amazon prime video

Can you watch other OnDemand programmes ok (this will test the internet connection)

Can you use other streaming services ok? - Try BBC iPlayer or YouTube.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
jgnotts
  • 25
  • 0
  • 4
On our wavelength
230 Views
Message 3 of 10
Flag for a moderator

Re: Amazon prime video

This has started happening to me and the only way I can get it working is to power the V6 box off completely and then back on again.

Prime then worked for a while before going wrong again needing me to reset again!

 

0 Kudos
Reply
Eeeps
  • 726
  • 46
  • 117
Rising star
229 Views
Message 4 of 10
Flag for a moderator

Re: Amazon prime video

This is a common problem that some people have more that others. I have two V6 boxes and in two years I've only seen this 3 times.

Suggestion is that it's something to do with the HDMI connection and the copy protection system.

What type of TV do you have, HD or UHD (I assume you haven't just changed it).

Suggested fixes are.

1. Change HDMI settings on the V6 box - try 1080p + passthrough
2. Reboot the box.
3. De-register and re-register the amazon account to the box (via the amazon web site) - reboot the V6 after the de-registration

jgnotts
  • 25
  • 0
  • 4
On our wavelength
187 Views
Message 5 of 10
Flag for a moderator

Re: Amazon prime video

This has happened to me twice in the last month and each time it was fixed by a power down and restart. Before this I’ve never had any issues with Prime. 

No settings have changed on my system and it’s still the same 1080p plasma. I have added a soundbar but I doubt it’s that.

 

0 Kudos
Reply
japitts
  • 8.57K
  • 1.2K
  • 1.66K
Very Insightful Person
Very Insightful Person
182 Views
Message 6 of 10
Flag for a moderator

Re: Amazon prime video


@Eeeps wrote:

This is a common problem that some people have more that others. I have two V6 boxes and in two years I've only seen this 3 times.

Suggestion is that it's something to do with the HDMI connection and the copy protection system.


Indeed. Virgin now enforce HDCP2.2 on any OnDemand in 2160. If any of your A/V kit isn't compatible with HDCP2.2 then there's a few things can happen. Somes a black screen after the lead-in adverts, other times an error 604.

https://www.virginmedia.com/help/virgin-tv-watching-4k-ultra-hd-content gives some useful advice on dealing with this, also https://www.virginmedia.com/help/virgin-tv-error-codes/604 gives the steps required.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
jgnotts
  • 25
  • 0
  • 4
On our wavelength
177 Views
Message 7 of 10
Flag for a moderator

Re: Amazon prime video

Everything in my setup is 1080p and I’m obviously not trying to watch 4K content.

 

0 Kudos
Reply
narc1999
  • 52
  • 0
  • 2
On our wavelength
164 Views
Message 8 of 10
Flag for a moderator

Re: Amazon prime video

A bit of digging and I think I have the solution.  Or at least one that worked for me.

Go into the Home menu--> Help & Settings--> Clear or Reset TiVo--> Restart TiVo--> Thumbs Down 3 times and Last Channel button. The box restarts which takes about 5minutes and then the apps work again.

0 Kudos
Reply
jgnotts
  • 25
  • 0
  • 4
On our wavelength
159 Views
Message 9 of 10
Flag for a moderator

Re: Amazon prime video

Isn't that just the same as pulling the power plug out and plugging back in again?

I did this and it worked for a couple of weeks and then went wrong again.

 

0 Kudos
Reply
Develle01
  • 2
  • 0
  • 0
Joining in
64 Views
Message 10 of 10
Flag for a moderator

Re: Amazon prime video

We couldn’t no. I had to unplug everything and plug it all back in for it to work.

0 Kudos
Reply