Menu
Reply
tommorey
  • 5
  • 0
  • 0
Joining in
1,673 Views
Message 1 of 12
Flag for a moderator

Amazon prime video not streaming videos

Anyone found a fix to get Amazon prime video working? I can get on the home page select a video, then it comes up with an error and says go to Amazon video help, which is of no use at all!

0 Kudos
Reply
Robert_P
  • 2.49K
  • 124
  • 206
Forum Team
Forum Team
1,598 Views
Message 2 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

Hello tommorey

 

Sorry to hear of the Amazon Prime issues, we know how frustrating this can be and thank you for raising this via the forums.

 

Does this happen on all devices? If not, which devices are you experiencing the issue on?

 

What connection are you using (wired or wireless)? What error message do you get when trying to watch content?

 

Rob

0 Kudos
Reply
tommorey
  • 5
  • 0
  • 0
Joining in
1,591 Views
Message 3 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

It's on the main tivo v6 box. And it's wired via virgin 200meg broadband.

  • It's just says video cannot play and to goto Amazon video play help. Which is no help at all.
0 Kudos
Reply
Lisa_CC
  • 3.96K
  • 236
  • 433
Moderator
Moderator
1,574 Views
Message 4 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

Hey tommorey,

 

Sorry I've a a few more questions to ask so we can help you with this.

 

Have you always had a problem watching Amazon Prime or has it recently started giving you issues? What about other Apps such as Netflix for example?

 

Can you try on a different device just so we can rule out the Amazon account issue?

 

When you're trying to watch Amazon Prime Video on your V6 box, is it via the app itself or via channel 205? Can you try both and do you get the same error?

 

Can you also check your HDMI cable and try a different HDMI cable and slot on your TV? 

 

Thanks,

 

Lisa

 

 

0 Kudos
Reply
tommorey
  • 5
  • 0
  • 0
Joining in
1,546 Views
Message 5 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

It is just on the virgin box it doesn't work, everything else works fine. It doesn't work either through the app or the channel.

I can get on the Amazon prime video home page and log in correctly. It just won't play the videos.

 

Thanks

 

Tom

0 Kudos
Reply
Paul_DN
  • 5.8K
  • 341
  • 613
Forum Team
Forum Team
1,540 Views
Message 6 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

Hi Tom,

 

Thank you for coming back to us, I have had a look at things our end and could see an issue which I have managed to rectify, please can you reboot your V6 box and try again.

 

Kind regards

 

Paul.

0 Kudos
Reply
tommorey
  • 5
  • 0
  • 0
Joining in
1,519 Views
Message 7 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

This has made no difference. I've tried deregistering and 're registering the divorce as well but still does work. It just says something went wrong, please try again later. Goto Amazon.com/video help

But this is of no use either. 

Tom

0 Kudos
Reply
David_Bn
  • 4.91K
  • 226
  • 402
Forum Team
Forum Team
1,504 Views
Message 8 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

Thanks for coming back to us tommorey!

 

Sorry to see you've had issues with the Amazon Prime Application, 

 

I'd like to take a closer look into this for you. Please check out the purple envelope in the top right hand corner for a PM from me

 

Kindest regards,

 

David_Bn 

0 Kudos
Reply
Garrygee
  • 5
  • 0
  • 0
Joining in
1,261 Views
Message 9 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

I have the same problem, it has worked for over a year now all of a sudden it doesn’t, I can watch trailers but films or programs just come up with the message Something went wrong, please try again later

0 Kudos
Reply
Eeeps
  • 753
  • 47
  • 118
Rising star
1,256 Views
Message 10 of 12
Flag for a moderator

Re: Amazon prime video not streaming videos

This must be a copy protection issue. When you go to play the item the app has to confirm it's playing to a valid device.
HDMI incorporates a handshake protocol that includes HDCP (High-bandwidth Digital Content Protection).
This was 'enhanced' for HDMI when used for UHD devices.

Do you have a UHD or standard HD tv?

I've only had this issue once on an HD TV and the de-register / re-register + reboot fixed it.

Others have changed the V6 HDMI settings. You could try that with a reboot.

0 Kudos
Reply