Menu
Reply
  • 9
  • 0
  • 0
charlieannear
Joining in
862 Views
Message 1 of 15
Flag for a moderator

Amazon Prime not working on V6 box

I’ve logged in to my Amazon Prime account, and can see the menu screens, but whenever I select a show to watch, all I get is the spinning wheel for a second or two and then a black screen. Nothing comes up no matter how long I wait, and if I press stop it goes back to the menu screen no problem.

V6 box seems to be working OK otherwise, Netflix works OK (although some programs won’t work, in a similar fashion, but at least I get an error message with those!)

0 Kudos
Reply
  • 3.91K
  • 261
  • 650
Roger_Gooner
Community elder
848 Views
Message 2 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

If you haven't done so, connect the V6 to the hub by Ethernet cable for best network speeds and reliability.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
  • 9
  • 0
  • 0
charlieannear
Joining in
819 Views
Message 3 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

Yep, it's connected by ethernet directly to the hub. Netflix works, other on demand services work, and I can stream to my old TiVo box

0 Kudos
Reply
  • 10
  • 0
  • 2
Halvten
Tuning in
746 Views
Message 4 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

I've got the same problem with Amazon Prime on the V6 box. In the evening, just a black screen. Useless!! It's  connected by cable and my internet speed is very fast...

I have absolutely no problems when streaming Prime on the iPad, iPhone or Android box.

  • 6
  • 0
  • 0
mwb2205
Joining in
719 Views
Message 5 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

Exactly same problem for me. Menu screen, but then nothing. Same as above, fast ethernet connection to my box.

0 Kudos
Reply
  • 33
  • 0
  • 2
Brinko
Tuning in
686 Views
Message 6 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

Same problem here. Was working fine until today. Never straightforward with Virgin is it. 

  • 1
  • 0
  • 0
ROB_DAVIS1990
Joining in
655 Views
Message 7 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

Exactly the same for me 

0 Kudos
Reply
  • 1.65K
  • 87
  • 210
Forum Team
Forum Team
572 Views
Message 8 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

Hello charlieannear

Thanks for your post on our forums

Sorry though to hear about the issues with Amazon Prime

How are things looking now?

Gareth_L

 

0 Kudos
Reply
  • 10
  • 0
  • 2
Halvten
Tuning in
529 Views
Message 9 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

Amazon Prime worked fine for a few days (I could even watch live tennis!) but now it's packed up again. It's fine on all my other devices (iPad, iPhone and iPad) It's just the V6 box that is never worked on consistently, apart from a few days this week. My internet speed is very fast and it's connected by wire.  

Do they not test the app before they push it out on the V6 box??

  • 2
  • 0
  • 1
Feena
Joining in
501 Views
Message 10 of 15
Flag for a moderator

Re: Amazon Prime not working on V6 box

I've got the same problem. Prime works fine on my laptop and the smart TV, but not through Virgin Media. I just get the black screen once I select a programme to play.