cancel
Showing results for 
Search instead for 
Did you mean: 

VM360 Channel 4 App - 4200-DRM-FAILED

Drizzle999
Joining in

When trying to play any progromme on the Channel 4 App I'm getting the dreaded "Well this is embarrasing" message accompanied by 4200-DRM-FAILED. Any ideas please folks?

I have unplugged it at the mains and left it for a couple of minutes but still the same. Other apps are working fine.

Funnily enough it manages to hit me with a couple of adverts each time first!

7 REPLIES 7

newapollo
Very Insightful Person
Very Insightful Person

Hi @Drizzle999 

DRM (Digital Rights Management) errors can sometimes be caused by a faulty HDMI cable, or an HDMI cable that has become partly unseated. Have you tried removing and re-inserting the HDMI cable, a different cable or different HDMI port?

Dave
I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

dc1987
Joining in

It’s doing the exact same thing for me, has been all day

NastyMe
Joining in

Has been the same for me as well

mtrewick20
Joining in

Same issue here, I have a wired connection and still the same error, any ideas when this can be resolved

I have tried the channel 4 App via Virgin 360 box and I get the same error message when trying to watch any content. The error reads "Well this is embarrassing. Something's not working. Please try again in a few minutes. 4200-drm-failed ".

I have a wired connection and have tried adjusting HDMI cables, Router/box off/on, but I have tried through a browser and I don't have this issue, this has been since I've tried from 9am today.

 

Thanks but no change.

Hi Drizzle999,

Thank you for reaching back out, have you tried a different HDMI slot either on the current TV or a different one?

Regards

Paul.