Showing results for 
Search instead for 
Did you mean: 

TV360 pairing with Samsung Frame remote

Joining in

Just got Virgin. I have a Samsung Frame 55 TV with a smart universal remote. I can get the remote to change channel by choosing 1008R as model number, but only for a few minutes. I've also tried Pace DR7111 as I read on here, but again only for a little while.

Can anyone tell me what the exact model is? Or is that a lost course?



Forum Team
Forum Team

Hi there @Gropes, welcome back to our forum and thanks for your post.

I'm sorry to see you have been having issues with pairing your Samsung remote. Have you been able to check this thread here to see if all the steps have been followed to help?

If you need any further help, please let us know.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

Yes. Ziggo is not an option and I've already tried Pace

Very Insightful Person
Very Insightful Person

Hi @Gropes 

Have you tried either Arris DCX960 or just DCX960?

You could also try Pace DCT7111

An oddiity, not sure if it will work on your Samsung Frame but you could also try selecting satellite box > tv directly
Then enter your postcode and select virgin
Select the HDMI port that your virgin box is connected to and hit Channel Up and select NO around half a dozen times times. After that it will offer you to search for model of your box manually.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Hey Gropes, thank you for reaching out and I am sorry to hear you are struggling to pair your remote up.

Has the advice given by newapollo helped at all? 

Please do let me know. Thansks

Matt - Forum Team

New around here?




I was having the same issue.   I manually chose Pace DCR7111 and it it now working perfectly!


@newapollo many thanks for the steer!