Menu
Reply
Highlighted
  • 8
  • 0
  • 3
Tuning in
258 Views
Message 1 of 3
Flag for a moderator

TV 360 box and Virgin TV Go app

We recently swapped out Tivo box for a TV360 box, and this has been set up OK to watch on a TV set. However, I watch some programmes on a desktop PC running Windows 10 and using Google Chrome as a browser.  I can successfully navigate to https://virgintvgo.virginmedia.com/ and can see the guide etc etc.  When I select a live programme to watch, I am asked to register my PC as a device, which I have done.  Unfortunately, when I return to try to watch the selected TV programme, I am asked again to register the same device registered seconds earlier.  When I open the settings tab and look at the 'Virgin TV Boxes' tab, I can see a Virgin TV box and a smartcard number. When I look at the 'Device Management' tab I can see that my PC is already registered.  I have tried again to watch live TV in my PC and have re-registered it as a device, but when returning to the TV programme, I'm again asked to register the same device??

There is no on-line help available for this box or this problem.  There doesn't seem to be any way of de-registering a device.  I've rand 150 several times, only to be passed from person to person, the last of whom asks me to go on hold and after around 5 minutes, the call hangs up.  The technical help provided by Virgin seems to be as useful as a chocolate fireguard!.

Are there any bright sparks out there who have a solution to this issue?

0 Kudos
Reply
Highlighted
  • 3.64K
  • 216
  • 280
Forum Team
Forum Team
114 Views
Message 2 of 3
Flag for a moderator

Re: TV 360 box and Virgin TV Go app

Hi drjataylor,

 

Thanks for posting and sorry to hear you're having some issues with TVGO.

 

This is a known issue, you can see more information on this here

 

Alex_Rm

0 Kudos
Reply
Highlighted
  • 8
  • 0
  • 3
Tuning in
111 Views
Message 3 of 3
Flag for a moderator

Re: TV 360 box and Virgin TV Go app

Ive received VERY unhelpful email from Virgin Media Community Support containing a link to a ‘solution’.

 
Almost ALL the people in the thread have the same issue as the one I’ve reported and is STILL! being investigated by your technical team.
I have exactly the same issue with the TVGO app on my iPhone.

If you take the time to send an email on this topic, please ensure that it contains information that is useful!
 
Regards
Jack Taylor
(Still awaiting a solution)
Tags (2)
0 Kudos
Reply