Showing results for 
Search instead for 
Did you mean: 

Sound not in sync on BBC channels

On our wavelength

Hi All,

I’ve just purchased a new Samsung TV and Soundbar. Everything works well and the picture and sound on BT Ultimate and Sky Sports UHD is fab, however we have noticed that the sound is slightly out of sync only on the BBC channels.

Does anyone know of a solution? I’ve changed the HDMI cables to newer better quality ones and the issue isn’t on the Apple TV we have or other VM channels only BBC 1,2 and News on VM?



Dialled in

I'm no expert on VM but with Sky you could adjust sound delay. On my TV I can also match screen and sound BUT I'd have thought every channel would be put by same.

On our wavelength

Yeh that’s the issue, it’s only on BBC channels, I adjusted the delay on BBC but then knocked everything else out 😕

I assume you have the 360 set to follow content for Dolby Digital or Atmos where available, does it make any difference to the sync problems on BBC if you set the audio to PCM 5.1 or 2.0.

How are we connected to the TV and soundbar, is it HDMI-ARC or 360 to soundbar then to the TV depending on the soundbar input's.



On our wavelength

So I've sorted it, but at the cost of Dolby Atmos on Sky and BT UHD.

I've plugged the Soundbar into the TV and instead of having the Virgin box go into the sound bar, I've also plugged it into the TV Directly. I've changed the Audio Output from Follow Contnent (recommended) to PCM 5.1 (HDMI Only). This has resolved the sound being out of sync on the BBC channels, but now stops Dolby Atmos from activating on BT Sport Ultimate and Sky Sports UHD which is very annoying.

I do like my soundbar, but it is the first one I've owned and I'm starting to think its more hassle than its worth.

Hi Jacobtribe,

It's not easy sometimes to find all the settings, if your TV and soundbar are connected by HDMI-ARC and the 360 is connected to the TV the same as my LG TV and soundbar, you need something like Digital Sound Output set to Pass through with the 360 set to follow content for Dolby Atmos, I also have a HDMI Input Audio Format set to bitstream.


On our wavelength

Thanks for the advice, those settings that solved the sync issue but it still won't trigger atmos. I'll keep playing about with it see if I can get it on.