Showing results for 
Search instead for 
Did you mean: 

Latest 360 update keeps failing

Tuning in


I have two 360 boxes, one updates with no problems and I like the various tweaks they are doing to 360.

However my other box keeps trying to update but when I go to the home page I keep getting an Oops ...connection problem message.

I have tried wired and wireless connections, both fail to update.

checked diagnostics in both and everything is good.

Is there any way to force a manual update, or has anyone solved this issue?



Very Insightful Person
Very Insightful Person

Hi @vrtual_climber 

Have you tried swapping the boxes around?

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Not applicable

The connection issue message normally appears when the Wi-Fi or Ethernet connection is lost. Have you checked your connected to the Hub securely?

If you navigate to the Settings menu and click network, select Wi-Fi connection and click on the Hub you’re currently connected to - it will show the signal as a percentage on screen. 

The ‘good’ signal you see when running diagnostics relates to the TV coax connection, and the bottom half of that pages shows if your speeds are good enough to watch HD and 4K content. 

Firmware updates require an Internet connection and can’t be forced. Though a reset of the box will trigger the latest firmware to be installed.

Failing that:

Press and hold the channel up and down buttons on the front of the box and turn the box back on whilst keeping the buttons pressed. Release the buttons when the welcome screen appears.

The standby button will begin to flash and a download icon should appear on-screen. Allow this to complete and the box will restart. See if this fixes the issue. 

Forum Team
Forum Team

Hey @vrtual_climber,

Welcome back to the community and thanks for taking the time to post your issue on the forums.
I’m sorry to hear of the issues that you’re having with your 360 box updating, have you tried the advice offered by the community members to get this resolved?

Please give it a try or let me know if you already have and we can look further into this.




Thanks for the tips, I tried checking the WiFi connection and all appeared to be in order.

I went for a factory reset, sadly it didn’t resolve the issue, and did involve a bit of reregistering of various apps.

i didn’t have time to go through reregistrion again so I didn’t try you final solution.

but the good news is, the update has at last kicked in, I am not sure if it is down to the reset, or dumb luck.

but thanks for your help


Hi vrtual_climber, 

Thanks for coming back to us and updating the thread. 

We're glad the new update has kicked in for you now. Whenever resetting the box, you would need to re-sign in to the apps so I can only apologise if you were unaware of this. 

Please let us know if you have any further issues though. 

Many thanks, 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs