Showing results for 
Search instead for 
Did you mean: 

Disney +

On our wavelength

I have the ultimate volt package which includes Netflix and Disney +. I was able to set up Netflix without any problems but whenever I try to set up Disney + via the my Virgin tv app it says there’s a technical fault and to try again later.

I have called technical support 8 times but there isn’t anyone who is capable to help me out. Is there anyone on this forum who has has the same issue? If so, did you manage to resolve it? 


Very Insightful Person
Very Insightful Person

Hi @Chrisdudbridge 

The Ultimate Volt package doesn't include Disney+ but it does include netflix.

Some Volt customers though do have either a 3 month or 6 month free access to Disney+, or a £2 a month discount on Disney +  as part of their  O2 Extras 

If you do have that O2 Extra then you should be able to sign into Disney + using your O2 credentials.

Otherwise you would need to register and pay Disney to access their app, either via your VM account, or directly to Disney.

The terms and conditions for Disney + via VM are on the following page. 


Are there any other apps you can't access?

Have you tried rebooting the 360?

You could also try factory resettting the 360.

To factory reset go to Settings (the cog at the end of the Home menu) > System > Factory Reset. It's actually misnamed and only a partial system reset and not a complete factory reset. You are given 2 options

Keep Recordings
Format Disk

Choose Keep Recordings, that means you won't lose your recordings and any planned recordings or series links you've set up. You will have to sign into your apps such as iPlayer, Prime, Netflix and ITVX again. Also Match frame rate and Standby power consumption will go back to their default settings if you have changed them.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

The person I spoke to specifically said I had Disney+ included in my package 

Hi Chrisdudbridge,

If you have received your O2 sim card download the My O2 app and select Disney+ from your Volt benefits to activate it. I tried for 2 day's online and it didn't work but worked straight away using the app.


Joining in


I have been having the same problem. I have recently moved to Virgin media, I got the bigger bundle plus movies and added Netflix and Disney+ to it. I also had no issues setting up Netflix, I also signed in with my Amazon Prime account fine, but when I try to set up Disney+ I keep getting an unexpected error message come up every time. I'm guessing that you have managed to get it sorted, as this was posted back in March. Could you possibly let me know how you got it sorted out please?

On our wavelength

If your issue is like mine and many others it means you do not have Disney +.  If I were you i would give up, it’s not worth the hours on the phone speaking to people who don’t know how the resolve the issue. 

Hi Kymmy88,

Thanks for posting and welcome to our community 🙂

Sorry to hear you're having some issues with Disney+. Can you confirm if the error is registering the Disney+ account or signing in?