Showing results for 
Search instead for 
Did you mean: 

Cannot access iPlayer

Joining in

I have recently signed up and have successfully used iPlayer to access programmes. I find I am now inexplicably stuck with the microphone icon and the message “go to iPlayer” on my screen. I can’t get rid of it and can’t use the Virgin Media service I am paying for.  Please advise.


Joining in

Until yesterday everything  had been functioning correctly.  Now there seems to be no escape from this on-screen message - microphone icon with “go to iPlayer” underneath, even if I switch off completely, reboot and switch on again. Any advice please?

You could try a factory reset.

Go to Settings > System > Factory Reset

You are given 2 options, select the keep recordings option,

Keep Recordings
Format Disk

Choosing Keep Recordings, means you won't lose your recordings and any planned recordings or series links you've set up, but you will have to sign into your apps such as iPlayer, Prime, Netflix and ITV X again, also Match frame rate and Standby power consumption will go back to their default settings if you have changed them.

Hi Lizzie77,

Thanks for posting and welcome to our community 🙂

Sorry to hear you've had some issues when watching iPlayer, have you been able to try what roy247 has suggested?


Hi Alex

Thanks for your message.

I haven’t tried yet. Not very tech savvy, I’m afraid. Not sure how I get to “settings” on TV screen if all I can see is the above frozen icon when I switch on. Some more guidance might help.


Assuming the remote is still working press the Home button then scroll across the menu at the top to the cog on the right hand side and then press OK, then go to System, Factory reset.

You did say you tried rebooting the box by turning the power off and on with either the switch on the back of the box or at the plug.

If the remote isn't working try replacing the batteries.


Thanks. I’ll give this a try, but also try the reboot again.

It worked! I rebooted again, and reset.  So everything’s working okay.  Thanks for your help.