Showing results for 
Search instead for 
Did you mean: 

Can't play Netflix through TV

Just joined

When I go to play Netflix it starts to load and then it gets to the 'N' and I just get the loading circle. I don't get an error message, it just stays like that until I cancel it.


Can't see anyway I can reinstall the app or change login details etc. 


Not keen on doing a factory reset of the box really. 


Would appreciate any help on this matter. 




Very Insightful Person
Very Insightful Person

Apps on Virgin TV boxes can't be reinstalled in the same way as on mobile devices. But when you do a factory reset on a TV360 box, there is an option to keep recordings.

Choose that option.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Thanks for getting back to me. 


Will this mean that I have to set up the box from scratch? Should this fix the issue? 


Thanks again

Very Insightful Person
Very Insightful Person

Hi @Forestboy21 

To factory reset go to Settings (the cog at the end of the Home menu) > System > Factory Reset. It's actually misnamed and only a partial system reset and not a complete factory reset. You are given 2 options

Keep Recordings
Format Disk

Choose Keep Recordings, that means you won't lose your recordings and any planned recordings or series links you've set up.

You will have to sign into your apps such as iPlayer, Prime, Netflix and ITVX again. Also Match frame rate and Standby power consumption will go back to their default settings if you have changed them.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Community elder

Have you just tried rebooting the box by turning the power off and on again with the switch on the back of the box.

If that doesn't work then try the factory reset, just select the option to keep your recordings.


Thanks all.


I did the factory reset and it's worked. I was just a little nervous doing it in case he needed to do a lengthy set up but it looks like it's remember the WiFi etc and I just need to sign into the apps again.


  • Thanks again all