Menu
Reply
Murphy0921
  • 6
  • 0
  • 0
Joining in
352 Views
Message 1 of 13
Flag for a moderator

CS2517 error

Since upgrading to the 360 box, I haven’t been able to watch catch up or on demand services on either of my boxes. I get the CS2517 error message. 

No one at customer support seems to be able to fix the issue. We’ve had 2 technicians out who confirmed there was nothing wrong with the signal, I’ve been given a new box and done a factory reset on the boxes but nothing has fixed the issue. 
The technicians believe the services haven’t been put on the account properly during the upgrade.

Can anyone advise anything else to try?

0 Kudos
Reply
newapollo
  • 11.25K
  • 1.53K
  • 3.35K
Very Insightful Person
Very Insightful Person
328 Views
Message 2 of 13
Flag for a moderator

Re: CS2517 error

Hi @Murphy0921 

Sorry in advance if this is too long and you've tried all the suggestions.

When you upgraded to the 360 was it a new box or a firmware upgrade?

It's highly likely that VM's back end systems haven't been updated to reflect you now have a 360 box and that 2nd level support would need to update the systems, although if tech support have changed the box then the systems should have been updated at that time.

Is this affecting all Catch Up/On Demand services all of the time, or just certain ones at certain times?

If it's just certain ones, then which channels and programs are affected?

 

Is the 360 connected to the internet via ethernet or wifi?

When I connect my 360 using 5GHz I often lose the signal to the 360, but have no problems using the 2.4GHz band.

If it's wifi try connecting to the 2.4GHz band (you might need to rename the SSID's on your hub to reflect this, I do this by adding 2G to the end of my SSID so it becomes VM123456782G instead of VM12345678)

Are you also using a third party router? If so make sure that it's connecting to the 360 with an IPv4 address in the 192.168.0.x range.

My brother in law had an issue using his 3rd party router, he'd checked some box on it and it was using IPv6 which VM don't yet support, even though it shows up in the 360 diagnostic screen. As soon as he turned off the IPv6 the 360 connected OK and played catchup/on demand.

If using an ethernet connection have you tried a different cable and/or port on the hub/3rd party router?

We also found he had issues with his connection when using an ethernet cable, however if he disconnected the ethernet cable and plugged it back in again then he was able to use catchup/ondemand.

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


I don't work for Virgin Media.

I'm a Very Insightful Person, I'm here to share knowledge. Learn more

Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks

The do's and don'ts. Keep the community welcoming for all. Follow the house rules
0 Kudos
Reply
Murphy0921
  • 6
  • 0
  • 0
Joining in
319 Views
Message 3 of 13
Flag for a moderator

Re: CS2517 error

We had an upgrade on one of the boxes and the TiVo box was replaced by a mini box.

I’ve tried both 5GHz and 2.4GHz but neither work.

Nothing can be watched via the tv for catch up and on demand even using the iPlayer, ITVhub or 4od apps. Programmes that are available to watch through the TV go app can be watched on the app. 

We are using a VM hub but it’s not the most up to date version. We can’t use an Ethernet cable, the box is in a different room

0 Kudos
Reply
japitts
  • 17.79K
  • 2.31K
  • 4.08K
Very Insightful Person
Very Insightful Person
313 Views
Message 4 of 13
Flag for a moderator

Re: CS2517 error


@Murphy0921 wrote:

We had an upgrade on one of the boxes and the TiVo box was replaced by a mini box.

We are using a VM hub but it’s not the most up to date version. We can’t use an Ethernet cable, the box is in a different room


So you previously had a V6 & a TiVo. The V6 was software-converted into a 360-master, and the TiVo was hardware swapped for a 360-mini.

It may have been useful if you'd have upgraded the TiVo to a V6, and then software-converted them both into 360-masters.. but unfortunately that's not an option now.

I'm minded towards this being a connectivity error, based on the info posted so far. If it were account-related, then VoD or other VM-services being problematic is entirely understandable. But third-party apps (albeit with VM-specific config) being an issue, seems odd. Are you able to try connecting one of your boxes via Ethernet, as an elimination exercise?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Murphy0921
  • 6
  • 0
  • 0
Joining in
310 Views
Message 5 of 13
Flag for a moderator

Re: CS2517 error

Ethernet isn’t working either. 

The problem with the apps is whatever program you select buffers but just doesn’t start playing

0 Kudos
Reply
japitts
  • 17.79K
  • 2.31K
  • 4.08K
Very Insightful Person
Very Insightful Person
305 Views
Message 6 of 13
Flag for a moderator

Re: CS2517 error


@Murphy0921 wrote:

The problem with the apps is whatever program you select buffers but just doesn’t start playing


That is an internet-connectivity issue all day long.

Edited to ask: Do any other internet-connected devices have problems in your home? Laptops, tablets, phones etc.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Murphy0921
  • 6
  • 0
  • 0
Joining in
288 Views
Message 7 of 13
Flag for a moderator

Re: CS2517 error

No, everything is working fine 

The problem is both technicians we had out couldn’t see any problems with the connection. 

The programs on the app do stop buffering but it just leaves a blank screen

Edited to add: the YouTube app works and there are no problems when playing videos

0 Kudos
Reply
newapollo
  • 11.25K
  • 1.53K
  • 3.35K
Very Insightful Person
Very Insightful Person
282 Views
Message 8 of 13
Flag for a moderator

Re: CS2517 error

Are the issues on both the main 360 box and the mini?

Have you tried swapping the boxes around?

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


I don't work for Virgin Media.

I'm a Very Insightful Person, I'm here to share knowledge. Learn more

Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks

The do's and don'ts. Keep the community welcoming for all. Follow the house rules
0 Kudos
Reply
Murphy0921
  • 6
  • 0
  • 0
Joining in
280 Views
Message 9 of 13
Flag for a moderator

Re: CS2517 error

Both boxes have the issue and I’ve tried swapping the boxes. It’s frustrating, I’ve probably phoned VM at least twice a week every week since the end of april but no closer to fixing the problem. 

0 Kudos
Reply
roy247
  • 2.18K
  • 158
  • 494
Problem sorter
261 Views
Message 10 of 13
Flag for a moderator

Re: CS2517 error


@Murphy0921 wrote:

.....

We are using a VM hub but it’s not the most up to date version. We can’t use an Ethernet cable, the box is in a different room


As long as you have the hub 3 or newer you will be OK, I have a hub 3 without any problems but I believe if you have a hub 2 you should have been supplied a new hub when you upgraded to 360.

 

0 Kudos
Reply