Showing results for 
Search instead for 
Did you mean: 

Amerzon prime app not working CS2400

Joining in

Amerzon app reports CS2400 fail.  Have power on/off,  router, tv box, in Amerzon deregistored device, factory reset tv box.  Checked internet connection on virgin tv box reports good high speed.

Still getting the same fault message now 48 hours still not working.


All other apps work. Have run checks reports fast internet connection. Have reset tv box and router.   Not working last 48 hrs.

Very Insightful Person
Very Insightful Person

Do other internet-based services work on the same box?

OnDemand, other streaming services - any of these are a good test.

If they work, this is an app-specific issue, if they don't - internet connectivity is the likely cause.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Hi Yes all the other internet apps and on demand work ok.  It did work before upgrade to 360.

Very Insightful Person
Very Insightful Person

Hi @DaveF56 

I was going to suggest factory resetting the 360 box and also checking  the internet connection but you've already tried that.

The CS2400 error mainly affects BBC channels, not apps  and is still being investigated see <<< this post >>> 

There is a workaround. to force the BBC  channel to play without the pop up reappearing. I don't know if it will work with the Prime app, but it's worth a try.

If you hit the back button on the 360 remote when the CS2400 error message appears, and then press pause and play hopefully the app will load.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Hi tried that a few times still doesn't work.

So all apps work except Amazon get a CS2400 error.   Internet connection is good from the diagnostics check.  Have reset tv box, and router, did a factory reset on tv box.   removed device from Amazon account.  Still doesn't work.  did the "back" then "pause" idea.  Still doesn't work.   It was always fine before 360 upgrade.  Worst thing I ever did.

Yes all other apps work.  So how do I get the Amazon app to work?  It was all ok before the change to 360.

Forum Team (Retired)
Forum Team (Retired)

Hi DaveF56, thanks for the posts and replies on our help forum and this thread.

We're sorry to hear you're having issues with your Amazon Prime App getting an error and hasn't worked since you switched to TV360.

We'd love to assist with this, could you please advise if your TV box connects over the WiFi or ethernet currently?

We'd also need to know if this happens when trying to watch Amazon Prime outside the TV box and/or on a different device, please check if possible and tell us if the same error comes up there?

We're here to assist you further where needed.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Connected by ethernet cable. My amazon prime works all ok on iPad, PC and mobile. have also now found other apps that dont work you tube and kids youtube.