Showing results for 
Search instead for 
Did you mean: 

Activate Netflix error

Joining in

Hi, I'm having problems activating Netflix through my account. When I click on 'Activate Netflix' in Entertainment Services I get a message saying "Sorry, something’s gone wrong! We’re having some technical issues. Please try again later."

I've tried it many times now at different times and it hasn't worked any time? Does anyone have the same issue or know a fix for it?




Do you already have a Netflix account signed in?  I had this issue,  I was already signed into my non-virgin Netflix account.  I factory reset my box (for another reason) and when going back into Netflix to login  it knew i was entitled to VM Netflix and could activate from the box.

Forum Team (Retired)
Forum Team (Retired)

Hi mcflin25,

Thanks for your post and welcome to the community.

Just to touch on @jamesredfern's advice, are you already signed into Netflix via Virgin?

Let us know,


I wasn't signed into Netflix no, I logged in and rejoined with a previous unsubscribed account through the Netflix app on Virgin.

Hi mcflin25 👋 thank you for letting us know! 

It sounds as though these issues are still ongoing for you, so I will send you a PM to confirm a few account details and offer further support! You can find my PM in the top right corner of the page in your Inbox 📩

We can return to this public thread with an update when possible! Thanks for your patience in the meantime!

All the best 🌞