Showing results for 
Search instead for 
Did you mean: 

360 remote not working and keeps flashing white light

Tuning in

I have a new virgin 360 remote, it has stopped working, and only just flashes white. I have tried to reset it, pressing the tv button with the rewind button. Done this for 10 seconds, and have then pressed the tv button, with the 0 button but it doesn't work, and the remote just flashes white in the corner. Have reset the tv box, and done the above steps again but again the remote doesn't work. Not sure what else I can try. 

Any help on this would be appreciated



Community elder

Sounds like you have the newer 360 remote, there has been a few posts saying they have removed the batteries to reset the remote and that has worked, maybe worth a try and also new batteries.


Taken the batteries out but have not tried putting brand new ones. Will try that and see if that makes a difference 


Did you find a resolution, I am having the same issue?


Nope gave up after trying everything, so called virgin and they are sending a new remote, but non the less is frustrating as is a brand new remote. 

Thanks for the reply. That is also what I have been told, they are sending a replacement remote. Seems a real waste. Very frustrating to have to wait for a new remote too, no TV for a week is a long time to wait!

If you have the TVGO app you can use that as a remote, and if you have a smart TV remote if you can pair it to the TV 360 you can also use that.

The 360 is paired to my LG magic remote as Ziggo Set-Top Box, you might need Ziggo Mediabox Next it depends on what your TV recognises.


Had this issue myself and found just repairing the remote fixed the issue failing that would be the batteries. Pairing is pressing tv and 0.