Menu
Reply
nickinsoton
  • 103
  • 1
  • 5
Dialled in
5,676 Views
Message 1 of 16
Flag for a moderator

"This site can't provide a secure connection" error

I have recently been unable to access the Reddit site through my Android phone when using mobile data - on wifi it works fine. I thought at first it might be a problem with the app I'm using but I also get problems when using the web browser (Chrome, also tried Firefox).

The error is "This site can't provide a secure connection - www.reddit.com sent an invalid response. ERRL_SSL_PROTOCOL_ERROR'.

It it only an issue accessing the Reddit site - all other sites I've tried are OK. I have tried clearing cached data in my browser and flushing DNS but this did not solve the problem.

The only thing that I have changed recently is to enable 2FA on my Reddit account. But, as I mentioned, since doing this the I can access Reddit fine on wifi.

Could it be that Virgin has blocked this site for me on mobile?

Edit: I forgot to mention that if I enable a VPN on my phone I can access Reddit via mobile.

 

 

0 Kudos
Reply
Natalie_L
  • 5.13K
  • 195
  • 399
Forum Team
Forum Team
5,658 Views
Message 2 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Hi nickinsoton, 

 

Thank you for reaching out to us here on the Community. 

 

We are sorry to hear you are experiencing issues when accessing Reddit.

 

Can you please access your account and check if you have child safety switched on? 

Also, do you have this problem with any other site?

 

Please let us know and we will be happy to help. 

 

Thanks 

 

 

 

 

Nat
0 Kudos
Reply
nickinsoton
  • 103
  • 1
  • 5
Dialled in
5,650 Views
Message 3 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Hi

Thanks for replying.There is no child safety setting turned on that I can see. I haven't found any other site that experiences this problem.

Nick

 

0 Kudos
Reply
Natalie_L
  • 5.13K
  • 195
  • 399
Forum Team
Forum Team
5,629 Views
Message 4 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Thank you for getting back to me. 

 

When you access the site, does it give you the error message but also give advanced options to bypass this?

 

If you could please also provide a screenshot of the error, it would be help if we have to raise this with IT. 

 

Thank you 

 

 

 

 

Nat
0 Kudos
Reply
nickinsoton
  • 103
  • 1
  • 5
Dialled in
5,626 Views
Message 5 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Nat,

There are no options I can see to bypass the error. Please find screenshot attached.

Nick

Screenshot_20211012-171628.jpg

0 Kudos
Reply
Travis_M
  • 3.6K
  • 128
  • 266
Forum Team
Forum Team
5,622 Views
Message 6 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Hi @nickinsoton

 

Just to double check, can you not access this when accessing switching between WiFi / Mobile data also?

 

Regards

Travis_M
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
nickinsoton
  • 103
  • 1
  • 5
Dialled in
5,620 Views
Message 7 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

on wifi it works fine, it's just 4G that's the issue

0 Kudos
Reply
Alex_RM
  • 6.31K
  • 328
  • 464
Forum Team
Forum Team
5,613 Views
Message 8 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Thanks nickinsoton,

 

Can you confirm if you've been able to test the SIM in a different handset? 

 

Alex_Rm

0 Kudos
Reply
nickinsoton
  • 103
  • 1
  • 5
Dialled in
5,590 Views
Message 9 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

I don't have access to another smartphone. But would the SIM  or phone be at fault if the website is accessible via VPN?

0 Kudos
Reply
Alex_RM
  • 6.31K
  • 328
  • 464
Forum Team
Forum Team
5,583 Views
Message 10 of 16
Flag for a moderator

Re: "This site can't provide a secure connection" error

Have you tried accessing this through the Reddit app? If not, can you try downloading the app? 🙂

 

Alex_Rm

0 Kudos
Reply