Showing results for 
Search instead for 
Did you mean: 

inbound calls don’t ring, they go straight to missed calls

Tuning in

I’ve had the problem for two years now where sometimes when people ring me, I don’t see the call come through and there is no notification, other than a missed call in my call recents.

It’s highly frustrating as I don’t know when someone has tried to contact me and I have to keep checking call recents.

I do not have do not disturb on and I’ve replaced the sim to see if it’s a sim issue but the new sim has the same problem.

How do I solve this? As I will have to leave Virgin Media if I cannot solve this asap!


Forum Team
Forum Team

Hey KK14, thank you for reaching out and I am sorry you are having some phone issues.

Please can you confirm if you can ring out and if you can do you have any issues doing this?

How long as this been going on?

What type of phone do you have and is it fully updated to the latest software?

Have you checked the 'phone' settings to see nothing is turned off at all?

Please can you try using WIFI calling and see if this issues still happens. Thanks 

Matt - Forum Team

New around here?

Hi Matt

Thanks for the reply.

Yes I can ring out and have no issues.

I have been a customer since 2018 and noticed issues two years ago.

My phone settings seem okay and I haven’t changed anything - I wouldn’t even know what to change.

I have WiFi calling turned on.


Hey KK14, thank you for letting me know this its an very odd thing for the phone to be doing.

Did this start happening when you got a new phone in 2018?

Please let me know what phone you have and I will look into this for you.

Does it let you get receive calls from using WIFI calling? Thanks 

Matt - Forum Team

New around here?

I didn’t notice / can’t remember this happening back in 2018. I have also changed my iPhone in 2021 and as mentioned changed my sim just a few weeks ago.

As far as I’m aware I’ve always had WiFi calling on so I’ve not noticed if it makes a difference. Should I turn it off? 

Hey KK14, thank you for confirming this.

No please do keep WIFI calling on because this use WIFI instead of your sim for a signal so this could be pointing to an issues with the handset.

Please can you go into settings - phone - diall assit and make sure that is turned off please.

Also can you please check your contact book for numbers that start with 07 instead of +44, if they have 07 at the start please change the format to +44 and let me know you get on with this. Thanks 

Matt - Forum Team

New around here?

My dial assist is turned off already and yes the numbers I’ve noticed issues with start with +44.


Hey KK14, thank you for confirming this.

This does sound like an issues with the actual device then, however I am going to send you a PM so I can do some final digging around.

Please look out for the purple envelope. Thanks 

Matt - Forum Team

New around here?