Menu
Reply
TonyGraham
  • 2
  • 0
  • 0
Joining in
926 Views
Message 1 of 4
Flag for a moderator

iPhone no names on messages

Since putting my virgin mobile sim in my iPhone will not display names on incoming calls or messages.  When I look at the contacts, the numbers are spaced in a weird way.

To fix, I can change my language and region settings to something else, then back to my English/UK setting and this sorts the problem for a short while.

if I also select ‘import sim contacts’ this seems to sort the issue, but only for a few hours.  

Spoke to virgin who suggested the import sim contacts thing, but as I said, this is a very short term solution.   It’s very very frustrating.

Can anyone offer any help?  Tried resetting the iPhone, restore, fresh install.  Problem always comes back.

Thanks

Tony

0 Kudos
Reply
enlli
  • 9.34K
  • 1.4K
  • 2.69K
Very Insightful Person
Very Insightful Person
917 Views
Message 2 of 4
Flag for a moderator

Re: iPhone no names on messages

Longstanding problem. Won't go into the technical details but

Try this and let us know it it works

Go to: Settings -> mobile data -> SIM Applications (near bottom) -> tap "Roaming"  -> tap "Select Mode"

Tap manual -> then choose National.

Usually fixes it.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
TonyGraham
  • 2
  • 0
  • 0
Joining in
908 Views
Message 3 of 4
Flag for a moderator

Re: iPhone no names on messages

Thanks for that.  Just gave it a try.  Switched the phone off and on again, but it’s not sorted it.

0 Kudos
Reply
enlli
  • 9.34K
  • 1.4K
  • 2.69K
Very Insightful Person
Very Insightful Person
903 Views
Message 4 of 4
Flag for a moderator

Re: iPhone no names on messages

Try doing the dial assist one more time and then turn it off. Then see if it returns.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply