Menu
Reply
Yeliab7491
  • 3
  • 0
  • 2
Tuning in
229 Views
Message 1 of 5
Flag for a moderator

VM supplied relacement sim not working

VM informed me I had to replace my sim due to a forthcoming upgrade.

Sim arrived early June. Did not work - "NO Sim", No useful help online.

Phoned 789 got a replacement early July.

Sim did not work - " NO Sim".

Tried Sim in my son's spare Iphone4, did not pick up the network.

Call Centre seems to be shut now due to CV19.  I have received several Warning txts saying my service cease if I don't put in new sim.

Seems like Sims are being issued BUT network doesn't know about them - maybe.

0 Kudos
Reply
Emma_C
  • 8.28K
  • 511
  • 549
Forum Team
Forum Team
179 Views
Message 2 of 5
Flag for a moderator

Re: VM supplied relacement sim not working

Hi Yeliab7491, 

Thanks for your post and welcome to our community. 

Really sorry that the SIM didn't work, this isn't good. 

Can I ask if the handsets you're using the SIM card in are unlocked to any network? 

I'll pop you a personal message as well so we can see what is going on and get this sorted. 

Emma_C - Forum Team
0 Kudos
Reply
Yeliab7491
  • 3
  • 0
  • 2
Tuning in
169 Views
Message 3 of 5
Flag for a moderator

Re: VM supplied relacement sim not working

Hi Emma_C,

my phone is not locked to any network. I bought it independently with a view to getting a Sim Only deal with VM.

BB

 

Yeliab7491
  • 3
  • 0
  • 2
Tuning in
137 Views
Message 4 of 5
Flag for a moderator

Re: VM supplied relacement sim not working

After 2+ weeks resolved the issue with help from Emma_C.

After trying this and that with the 2nd SIM, Emma_C arranged for me to get yet another SIM and she ensured that it was enabled. This meant that the issue was somewhere else.

In desperation I tried my wife's sim in my phone - it didn't work, then I tried the new shiny Sim in my wife's and it made contact with the network. Switched the Sims back and both phones were still working.

For some reason my phone had become 'locked', maybe when my old sim was disabled.

Many thanks to Emma_C for her help. 😊

Alex_RM
  • 4.3K
  • 247
  • 327
Forum Team
Forum Team
128 Views
Message 5 of 5
Flag for a moderator

Re: VM supplied relacement sim not working

Great to hear Emma was able to resolve this 🙂

 

I've passed your feedback along. 

 

Alex_Rm

0 Kudos
Reply