Menu
Reply
jalvesrz
  • 6
  • 0
  • 0
Joining in
650 Views
Message 1 of 12
Flag for a moderator

UK incoming number showing as Russian

I recently migrated to virgin media from another network.

Since I moved to Virgin, from time to time, incoming UK mobile numbers are displayed wrongly. Instead of 07xxxxxxxxx they are being displayed as +7(xxx) xxx-xx-x with a Russian country ID. 

Even saved contacts appeared like that every other time. Making it difficult to know who is calling. 

0 Kudos
Reply
enlli
  • 6.58K
  • 1.04K
  • 1.82K
Very Insightful Person
Very Insightful Person
637 Views
Message 2 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

Settings -> mobile data -> SIM Applications (near bottom) -> tap "Roaming"  -> tap "Select Mode"

I found "automatic" was selected by default.

Tap manual -> then choose National.

Now make sure your numbers are set to the correct format. If not change region to anything other than UK (Settings -> General -> Language and Region -> Region) and then change back to UK region

If you can't see manual it may say Virgin, use that

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
jalvesrz
  • 6
  • 0
  • 0
Joining in
626 Views
Message 3 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

Thank you for the prompt response.

 

I did what you said in the first part.

 

I confused by what you are saying the the second part, though.

All my contacts are fine. They are saved normally. No problem there. 

It’s the caller ID that’s having an issue. For example,

I have my wife number saved as 07488xxxxx.

Sometimes the caller ID will say “Wife”, other times it will say +7 (488) xxx-xx-x.

I also have a feeling this is only happening to mobile numbers that are from Vodafone my previous network. 

I will try to attach some examples.

D29ED152-9194-473D-AB46-409A381F12D6.jpeg

D6E14B2D-BD09-467B-8F72-1E21BEAE3AC6.jpeg

0 Kudos
Reply
enlli
  • 6.58K
  • 1.04K
  • 1.82K
Very Insightful Person
Very Insightful Person
616 Views
Message 4 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

It may correct it as this is a known problem between Virgin SIM cards and iPhone.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
jalvesrz
  • 6
  • 0
  • 0
Joining in
575 Views
Message 5 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

it did not work

0 Kudos
Reply
Tom_F
  • 2.8K
  • 160
  • 347
Forum Team
Forum Team
555 Views
Message 6 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

Hi jalvesrz, thanks for getting in touch.

 

Sorry to hear about this problem you've encountered with your contacts. The steps advised by enlli would usually help get around this it's odd that wasn't the case on this occasion.

 

Have you tried deleting a contact and manually re-adding it to see if that helps? I appreciate that's not an ideal solution as may take some time if it's a problem with numerous contacts.

 

Tom

0 Kudos
Reply
ps2mint
  • 57
  • 7
  • 15
Dialled in
553 Views
Message 7 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

I know it’s a bit of a pain, but I sorted this issue out by manually changing all of the numbers in my address book to +44 7 etc.

Since I did this I have not had a recurrence of this issue.

Hope it helps!

0 Kudos
Reply
jalvesrz
  • 6
  • 0
  • 0
Joining in
549 Views
Message 8 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

No, it hasn’t fixed anything. If anything now it has made it worse. Before it was only mobile and now with Landline too! I am also getting this issue with non contacts... and that’s what I am struggling with. So it’s pointless changing my contacts to whatever’s. Random people will call me, even from landline and it’s either listed as Russia (mobile) or United States (landline). This is so annoying and getting frustrated. 

0 Kudos
Reply
jalvesrz
  • 6
  • 0
  • 0
Joining in
548 Views
Message 9 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

All my contact numbers were already set with country code because of WhatsApp. 

Sometimes contact numbers will work fine, sometimes it won’t.

Non contacts are mainly the problem as they all appear like that. Now it’s doing on landline number too.

 

DD7DB54B-3C26-4DBD-80A8-25159B9ED2CE.png

0 Kudos
Reply
Tom_F
  • 2.8K
  • 160
  • 347
Forum Team
Forum Team
531 Views
Message 10 of 12
Flag for a moderator

Re: UK incoming number showing as Russian

Sorry you've encountered this problem @jalversrz.

 

Further to hat Enlii suggested - can you please try Russia first of all (under SIM applications as part of the first step) and make sure that's selected/saved, then go back in and select UK & save - and let us know if that helps at all? 

Tom 

0 Kudos
Reply