Menu
Reply
Deano1972
  • 11
  • 1
  • 0
Tuning in
370 Views
Message 1 of 5
Flag for a moderator

Text Numbers

Following the latest update from Apple, all of my text history has changed to +44 numbers rather than the contact they are stored under. If someone phoned me it comes up with their number rather than their contact name. 
If I go into a text message go to the sender then their info it has come in as a +44 if you then click on info it shows the normal contact and the +44 number. 
It’s done it 3 or 4 times since I moved to Virgin mobile, but normally rectifies itself after several hours, it’s now been 2 or 3 days. I’ve tried all the quick fixes online and no success. I contacted Apple support who accessed my phone and it’s not a phone issue, they asked who my carrier is when I told them Virgin they said it’s a carrier issue either network or sim as they have had several reported issues of the same with Virgin.  There are 3 other iPhones in our house that have all done the same update and they’ve had no issues on SkyMobile or Three. 

0 Kudos
Reply
Deano1972
  • 11
  • 1
  • 0
Tuning in
355 Views
Message 2 of 5
Flag for a moderator
Helpful Answer

Re: Text Numbers

Following the latest update from Apple, all of my text history has changed to +44 numbers rather than the contact they are stored under. If someone phoned me it comes up with their number rather than their contact name. 
If I go into a text message go to the sender then their info it has come in as a +44 if you then click on info it shows the normal contact and the +44 number. 
It’s done it 3 or 4 times since I moved to Virgin mobile, but normally rectifies itself after several hours, it’s now been 2 or 3 days. I’ve tried all the quick fixes online and no success. I contacted Apple support who accessed my phone and it’s not a phone issue, they asked who my carrier is when I told them Virgin they said it’s a carrier issue either network or sim as they have had several reported issues of the same with Virgin.  There are 3 other iPhones in our house that have all done the same update and they’ve had no issues on SkyMobile or Three. 

0 Kudos
Reply
enlli
  • 9.05K
  • 1.37K
  • 2.61K
Very Insightful Person
Very Insightful Person
339 Views
Message 3 of 5
Flag for a moderator
Helpful Answer

Re: Text Numbers

Virgin SIM cards are Belgian and are none standard. iPhones get confused sometimes. Usually this fixes most of the problems

Go to:

Settings -> mobile data -> SIM Applications (near bottom) -> tap "Roaming"  -> tap "Select Mode"

I found "automatic" was selected by default.

Tap manual -> then choose National.

You may need to set Dial assist afterwards.

 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
Deano1972
  • 11
  • 1
  • 0
Tuning in
335 Views
Message 4 of 5
Flag for a moderator

Re: Text Numbers

Thank you for your help. I managed to speak to a Virgin adviser earlier and he gave the following fix which has cured the issue. 

Settings, phone, dial assist turn off

Settings change language to English US

Restart phone

Settings, phone, dial assist turn on

Settings change language to English UK

0 Kudos
Reply
enlli
  • 9.05K
  • 1.37K
  • 2.61K
Very Insightful Person
Very Insightful Person
330 Views
Message 5 of 5
Flag for a moderator
Helpful Answer

Re: Text Numbers

I would still do the other fix, which usually stops the problem reoccurring causing you to go through the whole proceedings again.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply