Showing results for 
Search instead for 
Did you mean: 

Priority App kicking me out

Tuning in

Priority just kicks me out when trying to sign in using Virgin? Worked fine last week, deleted and reinstalled app but still not working??




[MOD EDIT: Subject title changed for clarity]


Forum Team
Forum Team

Hey lynds, thank you for reaching out and  a warm welcome to the community, I am sorry you are having some issues with the priority app.

We are aware of an issue which is affecting people from joining up / logging in and this is being worked on as we speak.

Please can you let me know what is happening, does it let you log in and then it kicks you out?

What phone do you have, IOS or Android? 

Is the phone and app fully updated? Thanks 

Matt - Forum Team

New around here?

It’s an i-phone 13, fully updated. I click on log in then it looks like it will log me in then just returns back to the log in page?

Hey lynds, thank you confirming this.

Okay have you tried to delete the app and reinstall this for the time being?

Does it also give you any error codes? Thanks 

Matt - Forum Team

New around here?

Yep….deleted, re-installed….couple of times

Hey Lynds, Okay thank you for letting me know. 

The team are working on an fix for this issues and hopefully we will have this back up and running shortly. Thanks 


Matt - Forum Team

New around here?