cancel
Showing results for 
Search instead for 
Did you mean: 

No mobile data

Plj
Tuning in

For some reason I don’t seem to be able to get data when I switch off WiFi.  As VM are removing WiFi hotspots I find I cannot browse the web at all when WiFi is turned off.  Even though the phone shows 5g it just hangs on any url I try to open.  This has been happening g for months and I am absolutely fed up with it - the phone becomes useless when out of WiFi reach !

 

as an example trying to get to the virginecare .com site with WiFi off I get the following error

 

To browse the internet, you need to buy a Data Add-on. We can't offer you one right now because we don't recognise this device. Please check the following:

• Turn WiFi off on your phone or device
Double check that you've got mobile data turned on
• If you're using Private Browsing - turn it off
If this doesn't work, or you're not connected to WiFi, call our team on 789.
 
I do have a data package (200gb) or should but it’s useless.  The phone is an iPhone 14 Pro Max and it’s a virgin media sim.
 
 
14 REPLIES 14

Steven_L
Forum Team
Forum Team

Hey Plj,

Welcome back to the community and thanks for taking the time to post.
I’m sorry to hear of the issues that you’re having with your mobile data at the moment, I have been able to locate you on our system and I have refreshed your network profile, please can you reboot your handset and let me know if that has helped at all.

Kind Regards,

Steven_L

Thanks Steven but I still get that page when browsing to virginecare.com (this is the page that I am taken to when I click the Network Provider Services link in the Mobile a data settings - maybe that page doesn’t work ?

 

also if I use the VIRGINMEDIA app and turn off WiFi to try and login to Mobile using the SIM I get a similar error

 

IMG_3166.jpeg

cje85
Trouble shooter

@Plj wrote:

Thanks Steven but I still get that page when browsing to virginecare.com (this is the page that I am taken to when I click the Network Provider Services link in the Mobile a data settings - maybe that page doesn’t work ?


I've just tried www.virginecare.com and it doesn't seem to exist. Do any other websites work?

 

Thanks for coming back to us Plj, please can you make sure your WiFi is fully turned off via settings rather than just by the quick option on the main screen. Are you getting the the 3g, 4g or 5g symbols, when trying to use your data connection?

Kind Regards,

Steven_L

Hi

 

WiFi is turned off in settings and I currently see the 4G connection symbol with 3 bars.

I have tried to add my virgin mobile number to my O2,account (I have an O2 account I’m my name for my wife’s phone) but am not able to add it to that - O2 says it cannot find any products for my own phone number which suggests it hasn’t switched to O2 yet - if that’s the case I wouldn’t expect to see the error telling me I haven’t switched to O2 on the virgin media app.

IMG_3166.jpeg

My sim is a virgin media sim (red) in case that is relevant.

(Oh and the more info link on the mobile app error doesn’t resolve it looks like the page has moved )..

 

 

thanks

Thanks for coming back to me Plj, we have looked into this and cannot see any issues with your account that would be affecting your data connection. Please can you check the coverage in your area via the O2 coverage checker this will work for O2 sims and Virgin Mobile numbers using the O2 network. 

Kind Regards,

Steven_L

brookheather
On our wavelength

You need to check your APN settings - if these are set incorrectly then you would have the symptoms of being unable to load data or webpages.

Says good 4G

IMG_3167.jpeg

 APN settings

 

IMG_3168.jpeg

Sometimes but sometimes not.  Take today - I was out near Frinton and tried to extend parking.  App wouldn’t load and I couldn’t log browse to the web page.  In the end I was 20 minutes late back and got a £45 parking fine .. this is really bad and I can only use my phone reliably  when I have WiFi - virgin are switching off the WiFi hotspots on the underground because they say everyone is using 4G/5g nowadays well unfortunately not me yet they still charge me every month.  I cannot login to the virgin mobile app without WiFi as I get the error

 

IMG_3166.jpeg

 and I cannot use the O2 app as my number isn’t recognised - I’m in limbo - how can I escalate this - £45 fine because an app wouldn’t load is not a great place to be ..

 

thanks