Showing results for 
Search instead for 
Did you mean: 

No messaging after porting

Tuning in

My number was meant to port over on Monday but didn’t so I got in contact yesterday and received a text earlier stating that my port had now gone through.

However, whilst I can now send SMS messages, I cannot receive them at all. My number in settings was wrong so I reset network settings to fix it which worked, but it seemed to make my iMessage and FaceTime fail. They are now failing activation and I’ve tried everything I can find online but they just keep failing. I thought I couldn’t receive texts due to the wrong number in my settings but it’s now changed to the correct one and I still cannot receive texts.

I’m not sure how to get any of this going again as I can’t receive any messages at all at this point and I’m not sure if it’s port related or not.


Forum Team
Forum Team

Hi cha_small, thank you for posting on our help forum and welcome to our community.

We're sorry to hear of the issues faced with your mobile text messages on iMessage and Facetime not coming through.

Could you please advise if you're currently using an iPhone or Android so we can best advise on this?

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hiya thanks for your quick response,

It’s the iPhone 14 pro. The iMessage and FaceTime settings just keep saying verifying next to my phone number and then activation failed. 

Thanks for your response, cha_mall.

Please, follow the below advice and steps and let us know if this is of any help:

Ensure you have the international prefix +44 before a number on your iPhone contacts.

If this doesn't help, check if you have Dial Assist enabled. To locate and enable this, head to Settings > Phone > Dial Assist.


If that's enabled but the issue remains, you need to reset your Language & Region. 
To do this, head to Settings > General > Language & Region > Region and then select United Kingdom. 


If the Region is already set to United Kingdom, select the region relevant to the prefix that's coming up, and then change it back to United Kingdom. This should help push the reset and correct the Region of the settings.

Tell us how you get on, we're happy to assist further in case the issue persists.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi yes I have all of those settings already on.

I’ve checked everything and can’t see why, I can send SMS texts to people but when they reply the texts don’t come through. 

My iCloud also now seems to have forgotten my number but in order to add it back to my account it needs to send a verification code which, as you can imagine is quite inconvenient as I can’t receive texts.

Without adding my number to my iCloud account I don’t think I’m going to be able to fix my iMessage and FaceTime issue so the most pressing problem at the moment is the fact that I cannot receive SMS from anyone despite my number supposedly porting over 

Morning cha_small

Please try this;

  • Turn off iMessage and FaceTime in Settings 
  • Reset phone 
  • Confirmed my telephone number is correct in Settings > Phone > My Number (i.e. showing the ported number) 
  • Turned iMessage and FaceTime back on

Also log out of the Apple ID and back in.

Best wishes,

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill