Menu
Reply
JP__
  • 2
  • 0
  • 1
Joining in
480 Views
Message 1 of 4
Flag for a moderator

New sim only switching numbers to Belgium

  • Hello. Put a sim only plan sim card in my mum's iphone8 that she was previously on EE with no problems. It's only been a day and certain numbers are dialling Belgium and no incoming caller ID is showing despite having numbers saved. My mum is elderly and relies on her mobile a lot. Have just signed up to 18 month ultimate oomph and regret it already. Can anyone help? Thanks. 
0 Kudos
Reply
newapollo
  • 10.46K
  • 1.44K
  • 3.09K
Very Insightful Person
Very Insightful Person
469 Views
Message 2 of 4
Flag for a moderator

Re: New sim only switching numbers to Belgium

Hi JP__

Go to: Settings -> mobile data -> SIM Applications (near bottom) -> tap "Roaming"  -> tap "Select Mode"

I found "automatic" was selected by default.

Tap manual -> then choose National.

Now make sure your numbers are set to the correct format. If not change region to anything other than UK (Settings -> General -> Language and Region -> Region) and then change back to UK region.

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


I don't work for Virgin Media.

I'm a Very Insightful Person, I'm here to share knowledge. Learn more

Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks

The do's and don'ts. Keep the community welcoming for all. Follow the house rules
JP__
  • 2
  • 0
  • 1
Joining in
443 Views
Message 3 of 4
Flag for a moderator

Re: New sim only switching numbers to Belgium

Hi Dave. Thank you very much, worked a treat! Top man 🙂 

Chris_W1
  • 4.61K
  • 206
  • 301
Forum Team
Forum Team
381 Views
Message 4 of 4
Flag for a moderator

Re: New sim only switching numbers to Belgium

Hi JP__, thanks for messaging us and welcome to the forums. I can see that the information provided by newapollo has rectified the issue for you. 

 

Please let us know if you need anything and have a good night. - Chris. 

0 Kudos
Reply