Menu
Reply
Discomike
  • 6
  • 0
  • 0
Joining in
283 Views
Message 1 of 4
Flag for a moderator

New payg sim not working in Germany

I have activated my new purple payg Sim here in the U.K (made phone call to test that it worked) and then shipped it out to my friend in Germany to use. unfortunately it won’t roam onto any network, automatically or by selecting manually.  My friend used to use her old Sim on o2.de but says when she tries the new sim to select this it says the Sim Card doesn’t allow connection to this network. Also tried Vodafone.de with the same issue.. Roaming is switched on and International call barring is turned off. Any suggestions ??

0 Kudos
Reply
Gareth_L
  • 6.94K
  • 424
  • 781
Forum Team
Forum Team
179 Views
Message 2 of 4
Flag for a moderator

Re: New payg sim not working in Germany

Hello Discomike

Thanks for bringing this matter to our attention 

Just a quick question 

Did you set up roaming on your online account when the saim was still in your phone 

Gareth_L

0 Kudos
Reply
Discomike
  • 6
  • 0
  • 0
Joining in
176 Views
Message 3 of 4
Flag for a moderator

Re: New payg sim not working in Germany

Roaming was always active as the number has been mostly used in Germany...I hadn’t changed anything

0 Kudos
Reply
DJ_Shadow1966
  • 7.14K
  • 1.36K
  • 2.02K
Very Insightful Person
Very Insightful Person
168 Views
Message 4 of 4
Flag for a moderator

Re: New payg sim not working in Germany

Hello
Thank for joining in on the forum, we will try the best to get your issue resolved.

You can try the following if you have the newer (last 2 years) purple sim card, you can try the sim tool to get it working,

How to access the sim toolkit.

For Android:
Select Apps from the Home Screen
Select Virgin SIM Toolkit Icon
Select Roaming
Select Select Mode
Select Manual
Select International-you are done, go back to Home Screen

To Switch back when in the UK:
Select Apps from Home screen
Select Virgin SIM Toolkit Icon
Select Roaming
Select Select Mode
Select Automatic and go back to Home Screen

For iOS:
Select Settings from the Home Screen
Select Phone Icon
Select SIM Applications
Select Roaming
Select Select mode
Select Manual
Select International and you are done, go back Home screen to retry

To change back when returning to the UK:
Select Settings from the Home Screen
Select Phone Icon
Select SIM Applications
Select Roaming
Select Select mode
Select Automatic mode - you are done, go back to Home screen

**It is important that you set the SIM roaming applet back to Automatic mode once in the UK or you will not be able to access service when you return.**

Regards Mike

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply