Menu
Reply
Highlighted
  • 1
  • 0
  • 0
Just joined
85 Views
Message 1 of 3
Flag for a moderator

New SIM no working and can't get any support.

I received a new SIM for my data only contract which I use in my car (Land Rover InControl) a couple of weeks ago. Swapped the SIM and it won't connect (my old SIM worked fine). There are no options on the Virgin Mobile website for me to try and resolve the issue and I can't get in touch with anyone by telephone. It's been 2 weeks now without a service I am paying for, I can't even just cancel my Direct Debit as my mobile account is on the same payment. Can anyone offer any advice??

0 Kudos
Reply
Highlighted
  • 3.88K
  • 528
  • 1.04K
Very Insightful Person
Very Insightful Person
67 Views
Message 2 of 3
Flag for a moderator

Re: New SIM no working and can't get any support.

The last few cases I've seen required the APN settings to be put in manually 

The settings are here

https://community.virginmedia.com/t5/Virgin-Mobile/New-Purple-Virgin-Mobile-SIM-and-need-the-APN-set...

 

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

0 Kudos
Reply
Highlighted
  • 5.48K
  • 765
  • 1.54K
Superstar
47 Views
Message 3 of 3
Flag for a moderator

Re: New SIM no working and can't get any support.

Does this thread help at all, it was for a Range Rover

https://community.virginmedia.com/t5/Forum-Archive/Data-only-Sim/m-p/3909252#M2137184

 

---------------------------------------------------------------
BB 200 - Hub 3, Phone Talk w/ends, Mobile Sim only. Customer since 1993.
0 Kudos
Reply