Menu
Reply
GeoffStone
  • 11
  • 0
  • 0
On our wavelength
88 Views
Message 1 of 2
Flag for a moderator

Incoming calls not shown as saved contacts

So recently switched to Virgin mobile. Ever since I have started to get seemingly random phone calls, where caller ID shows the actual phone number. It appears that these aren’t random numbers but people I know and for whom I have contacts saved on my phone.

A look at the contact shows that my contact telephone numbers have been reformatted so instead of 07956 123 456, the number now reads 07 95 61 23 45 6. Or similar. This would probably explain why incoming numbers aren't being matched to contacts.

Googling tells me that this seems pretty common and is something to do with virgin routing calls through Belgium or something. There is a supposed fix to reformat all phone numbers in international calling prefix. Problem is that most of my numbers already are, yet the problem persists. Also if you switch your region to Belgium and then switch it back, the problem goes away. Until the next time. 

So my question is, is this a known issue, and why is this happening. Finally, is there an absolute fix for this? 

thanks

 

0 Kudos
Reply
enlli
  • 7.41K
  • 1.17K
  • 2.09K
Very Insightful Person
Very Insightful Person
67 Views
Message 2 of 2
Flag for a moderator

Re: Incoming calls not shown as saved contacts

By your description I presume you have an iPhone 

This should work.

Go to: Settings -> mobile data -> SIM Applications (near bottom) -> tap "Roaming"  -> tap "Select Mode"

Tap manual -> then choose National.

Make sure your numbers are set to the correct format. If not change region to anything other than UK (Settings -> General -> Language and Region -> Region) and then change back to UK region.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply