Menu
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
99 Views
Message 1 of 5
Flag for a moderator

Incoming UK numbers appearing as international on phone

Since I installed my new Virgin sim, all coming calls are showing in wrong format and telling me they are international. What can I do?

0 Kudos
Reply
Highlighted
  • 1.86K
  • 69
  • 136
Forum Team
Forum Team
47 Views
Message 2 of 5
Flag for a moderator

Re: Incoming UK numbers appearing as international on phone

Hi Janice9,

 

Welcome to the Community and thank you for getting in touch.

 

Our apologies for the delay in response. 

 

I have taken a look and this issue seems to appear mainly on iPhones, is this the case for you please? 

 

Thanks 

 

Nat
0 Kudos
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
29 Views
Message 3 of 5
Flag for a moderator

Re: Incoming UK numbers appearing as international on phone

Yes, I have an iPhone but the iPhone community tell me it is a carrier issue not a phone issue
0 Kudos
Reply
Highlighted
  • 5.84K
  • 923
  • 1.61K
Very Insightful Person
Very Insightful Person
22 Views
Message 4 of 5
Flag for a moderator
Helpful Answer

Re: Incoming UK numbers appearing as international on phone

This should fix it

Goto

Settings -> mobile data -> SIM Applications (near bottom) -> tap "Roaming"  -> tap "Select Mode"

I found "automatic" was selected by default.

Tap manual -> then choose National.

If National is not there choose Virgin

Reboot the phone afterwards 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Highlighted
  • 3
  • 0
  • 0
Joining in
17 Views
Message 5 of 5
Flag for a moderator

Re: Incoming UK numbers appearing as international on phone

Thanks - have done this and changed to Manual - will have to wait for a non iPhone call now to check if it's worked
0 Kudos
Reply